1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Too Many Redirects (Safari / Mac)

Discussion in 'Installation, Upgrade, and Import Support' started by squashlover, Oct 21, 2014.

  1. squashlover

    squashlover New Member

    Users on Mac using Safari are reporting:

    Code:
    " Too many redirects occurred trying to open "forums.kombiclub.com". This might occur if you open a page that is redirected to open another page which then is redirected to open the original page."
    We do have SEO urls on, but afaiaa this is the stock htaccess/rewrite.

    Any solutions?
     
  2. Jim Boy

    Jim Boy Well-Known Member

    Firstly have you tried adjusting it and found that didn't fix the solution? More than once I've fallen for the trick of actually fixing a redirect issue like this but not realising it was fixed becuase my browser had cached the redirect instruction - just had to shut the browser down and back up again.

    Secondly the stock method works, so without posting of a htaccess file or similar, it will be hard to troubleshoot
     
  3. Mike

    Mike XenForo Developer Staff Member

    I certainly haven't had any issues, though I haven't confirmed with Mac Safari specifically. That said, redirect rules are not traditionally done with browser-based conditionals, so I don't think there'd be any reason for that with the default setup.
     
  4. squashlover

    squashlover New Member


    Code:
    #   Mod_security can interfere with uploading of content such as attachments. If you
    #   cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #   SecFilterEngine Off
    #   SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
       RewriteEngine On
    
       #   If you are having problems with the rewrite rules, remove the "#" from the
       #   line that begins "RewriteBase" below. You will also have to change the path
       #   of the rewrite to reflect the path to your XenForo installation.
       #RewriteBase /xenforo
    
       #   This line may be needed to enable WebDAV editing with PHP as a CGI.
       #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
       RewriteCond %{REQUEST_FILENAME} -f [OR]
       RewriteCond %{REQUEST_FILENAME} -l [OR]
       RewriteCond %{REQUEST_FILENAME} -d
       RewriteRule ^.*$ - [NC,L]
       RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
       RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    I enabled SEO urls yesterday and users started reporting issues soon after. I can only test on iphone and win7 safari - which I will do now.
     
  5. squashlover

    squashlover New Member

    Cannot replicate on Win7 Safari 5.x (Apple have not updated to 6.x on Windows)
     
  6. squashlover

    squashlover New Member

    and am not able to replicate on iphone 4 safari.
     
  7. Mike

    Mike XenForo Developer Staff Member

    Just so you know, I checked with Mac Safari and had no issues.
     
    squashlover likes this.
  8. squashlover

    squashlover New Member

    Thanks Mike, appreciated. Oddly, one of the users thanked me for fixing it just now and I haven't done anything. So perhaps a cache at the user side or, maybe a few of them hit the site when I was switching over to SEO urls the other day?
     
  9. Amin Sabet

    Amin Sabet Well-Known Member

    I enabled SEO URLs today and already have a Safari user telling me that they are getting this too many redirects issue. I'll clear caches and see how it goes.
     
  10. Robust

    Robust Well-Known Member

    Cannot replicate, I use 2014 MBP with Safari every day. Never had this issue. Perhaps your setup? Try Mac Chrome or something, see if it's your browser or the server. If it's fine with Chrome on Mac, clear data on Safari and try again. If it's not fine with Chrome on Mac (or any browser on any platform), I'd check your web server setup.
     
  11. Amin Sabet

    Amin Sabet Well-Known Member

    I can't replicate it on my Macs either, but I don't think it's a coincidence that my member is having this issue right after I enabled SEO URLs, and squashlover had the same experience.

    Update: That member confirmed that clearing his browser cache fixed the problem.
     
    Last edited: Feb 20, 2015

Share This Page