Thread Thumbnail by AddonsLab

Thread Thumbnail by AddonsLab [Paid] 2.10.0

No permission to buy ($29.99)

securedme

Active member
How is this compared with [Xenbros] Auto Thread Thumbnail? They seem to do similar things.

1) Is there an option to set the dimensions of the thumbnails? Currently it's around shape. I would like to see rectangular thumbnails.

2) Currently the thumbnail is not an image with reduced size but instead it's just an original image with smaller dimensions set. It will load slowly if most images are big.
 
Last edited:

El Porcharo

Well-known member
Is there any chance to exclude the thumbnail in data-template="forum_list" only?

I see we only have an option to set "forum view only", but this would exclude "what's new" and so on...
 

AddonsLab

Well-known member
Is there any chance to exclude the thumbnail in data-template="forum_list" only?

I see we only have an option to set "forum view only", but this would exclude "what's new" and so on...

Forum view only option would enable thread thumbnail only on forum view, and disable on all other locations. As I understand, you need the opposite of it, to disable thumbnails on forum view but keep them on all other locations. We don't have such option for now, but we may implement it in the next update.

Thank you!
 

El Porcharo

Well-known member
you need the opposite of it, to disable thumbnails on forum view but keep them on all other locations.
Not really, I mean the Xenforo home page, where you can see the list of all nodes.

Every nodes shows the latest thread in the right side, along with the user avatar.
Also the "latest threads" widget shoes user avatars.

And when these threads comes with a thumbnail, it is shown instead of the avatar.

I want to restore the user avatar in these two positions (in the node list page), because my thumbnail are rectangular while the avatars are circular and you can't see the image inside since it is all very small circles.


But I could also use custom CSS if there is a way to do address those avatar placeholder
 

AddonsLab

Well-known member
Not really, I mean the Xenforo home page, where you can see the list of all nodes.

Every nodes shows the latest thread in the right side, along with the user avatar.
Also the "latest threads" widget shoes user avatars.

And when these threads comes with a thumbnail, it is shown instead of the avatar.

I want to restore the user avatar in these two positions (in the node list page), because my thumbnail are rectangular while the avatars are circular and you can't see the image inside since it is all very small circles.


But I could also use custom CSS if there is a way to do address those avatar placeholder

I see, I guess the best would be having an option where you can list template names where the add-on would be inactive. This option would be checked before making the template modification, so the original HTML and CSS remain intact if the thumbnails are disabled.

We will let you know once the feature is implemented.

Thank you!
 

z3r010

Active member
I notice the thumbs don't work correctly in the XF enhanced search Similar thread widget, the thumbs can be set/reset from there but don't stick.

Is this a bug or are they not intended to work there? either way, can it be fixed so they do work there?
 

AddonsLab

Well-known member
AddonsLab updated Thread Thumbnail by AddonsLab with a new update entry:

Template blacklist option

The release implements an option to specify the names of page templates for which you would like to disable the thumbnails. Specifying "forum_list" would remove the thumbnail for the home page, forum_view would remove the thumbnail for the thread list page etc. This version also implements support for Similar Threads widget from Enhanced Search add-on.

The new version is available for all licensed customers at https://customers.addonslab.com/marketplace.php/my-services/

Thank you!

Read the rest of this update entry...
 

z3r010

Active member
Any chance we could get the thumbnails added to the tag view page? I think this is the last place where an avatar still shows rather than the thumbnail.
 

CavySpirit

Member
Would it be at all possible to put the thumbnail to the right of the thread title in its own separate column? Great to indicate when there IS an image in a thread and a clue to what it is, rather than totally replacing the user's avatar? It seems like it would stand out more and be less confusing for my purposes.
 

AddonsLab

Well-known member
Would it be at all possible to put the thumbnail to the right of the thread title in its own separate column? Great to indicate when there IS an image in a thread and a clue to what it is, rather than totally replacing the user's avatar? It seems like it would stand out more and be less confusing for my purposes.
It is in general possible. Feel free to contact us at https://customers.addonslab.com/submitticket.php?step=2&deptid=1 for a quote if you are interested in funding the development.

Thank you!
 
After installing on Xenforo latest, it doesn't provide any options when creating a thread for selection of thumbnail. Any suggestions?
 

drastic

Well-known member
Hey,

I uploaded an image, to a thread, that is large enough to get a big preview on FB. When scraping the post on FB, it seems like the thumbnail got resized much smaller, so no longer shows the big preview.

What should I do to make sure our uploaded image stays the way it is, so we can get that nice looking pic on FB?

Do I have to set an image size somewhere? Or disable resizing? Wasn't sure where to look these days.

Thanks!

UPDATE: had to set dimensions for thumbnail on XF settings... :) this is good for social shares, in case anyone else needs it.
 

AddonsLab

Well-known member
Hey,

I uploaded an image, to a thread, that is large enough to get a big preview on FB. When scraping the post on FB, it seems like the thumbnail got resized much smaller, so no longer shows the big preview.

What should I do to make sure our uploaded image stays the way it is, so we can get that nice looking pic on FB?

Do I have to set an image size somewhere? Or disable resizing? Wasn't sure where to look these days.

Thanks!

The add-on should have used the URL of the full version for the meta tag, but that would not be the case if guests are not allowed to view full attachments on your board. Please copy an attachment URL (with index.php?attachments/..) and try to access it in Incognito mode to see if permissions are possibly the problem.

Thank you!
 

drastic

Well-known member
The add-on should have used the URL of the full version for the meta tag, but that would not be the case if guests are not allowed to view full attachments on your board. Please copy an attachment URL (with index.php?attachments/..) and try to access it in Incognito mode to see if permissions are possibly the problem.

Thank you!

A permission setting was incorrect on my end, thanks for pointing that out.
 
Top