1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

There was a problem uploading your file.

Discussion in 'XenForo Questions and Support' started by onyxchase, Apr 28, 2012.

  1. onyxchase

    onyxchase Active Member

    Hi. I have just upgraded my server but I am getting this error. "There was a problem uploading your file."

    Is there any way of getting more details on the error? I made sure my data and internal_data was set to 777 and ran the file check without any problem. I've enabled debug mode but it still doesn't give me any more information.
     
  2. onyxchase

    onyxchase Active Member

    This only seem to happen with the Flash Uploader, When I turn it off I can upload fine. Weird.
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That error is not specific.

    Is your forum behind a htaccess login? The flash uploader doesn't function in that situation. That's the only thing I can think of off hand.
     
    MsJacquiiC likes this.
  4. onyxchase

    onyxchase Active Member

    No it's a public forum that everybody can see. It's weird because I switched server and it used to work fine on the old server. Anyhow, I switched to the other uploader and it's fine, it's just that the flash looks better. ;)

    It does allow me to select a file and to click on Upload, but then it gives me an error.
     
  5. onyxchase

    onyxchase Active Member

    I found the problem. It was mod_security. I tried to disable it via .htacces but it didn't work, so I had to manually add a rule in my modsec2/custom.conf, see this post for more info. Thank you for your help!
     
    Power Lifter and Jake Bunce like this.
  6. hdj

    hdj Member

    My forum has this error also and disable the Flash Uploader can fix it.
    Maybe it is a bug of XF.

    System Centos 5x64 LNMP.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    For onyxchase, mod_security was responsible for the error. This is not uncommon. Some web hosts are too restrictive about their server rules which can interfere with legitimate requests, not unlike a spam filter that catches legit emails.

    Check your logs on the server. And contact your host to have them check the mod_security rules.
     
  8. hdj

    hdj Member

    Ok and Thanks.

    I am using VPS so will check it myself...
     
  9. bashy

    bashy Member

    Logs are amazingly helpful sometimes...
    Even if it says "Permissions error", it's still helpful to you.
     
  10. Markus

    Markus Member

    I have this same issue on my VPS, seeing as apache2/error.log gave me the following line of text, I'm sure I can fix this in a sec :)
    Code:
    [Fri Jun 22 13:19:02 2012] [error] PHP Warning:  POST Content-Length of 13071976 bytes exceeds the limit of 8388608 bytes in Unknown on line 0
     
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try adding these lines to your library/config.php file:

    Code:
    ini_set('post_max_size', '16M');
    ini_set('upload_max_filesize', '16M');
    
    If that doesn't work then you may have to increase these settings in the php.ini file on the server.
     
    Markus likes this.
  12. bashy

    bashy Member

    Didn't want to start a new thread about this as there's quite a few going around.

    I've set everything in php.ini to 125M and execution time is 960
    I'm trying to upload a 1.15MB .rar file and it fails at 30% every time.

    Is it something browser side because others can upload and it randomly worked once today but been trying again and it's failing still.

    [​IMG]

    EDIT: Works fine on Firefox (latest)
     
  13. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That's interesting... that this error could be a client problem.

    Try disabling the flash uploader:

    Admin CP -> Home -> Options -> Attachments -> Use Flash Uploader

    Does that fix it?
     
  14. bashy

    bashy Member

    Actually, this is the uploader which was on my Firefox (didn't have flash installed), must be why it worked :)
    Thought that was just different for Firefox...

    Worked on Chrome with non-flash version.
     
  15. Markus

    Markus Member

    I'm afraid my server administrator already fixed this by sorting the configuration memory usage values (Which had not been defined in the files), to be fixed for apache or w/e module was using them. Only If I had known the above before, thanks a lot.
     
  16. Bellinis

    Bellinis Active Member

    One of my users also reported that since recently he is unable to attach images to a post.
    In IE it works, in Firefox it doesn't.

    What could be the problem?

    Thanks!
     
  17. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Let's be clear. What is the error you are getting?
     

Share This Page