1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed The problem with Warning

Discussion in 'Resolved Bug Reports' started by Gatses, Mar 3, 2015.

  1. Gatses

    Gatses Member


    I have a forum installed 2 languages (English and Russian). Selected Russian language, press "Warn" message. Interface warning change the language to English. Click "Warn member" and there is a notice:
    Romchik® likes this.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I am unable to reproduce this.

    Does it happen in a default style with all add-ons disabled?
  3. Gatses

    Gatses Member

  4. imthebest

    imthebest Formerly Super120

    I have been using the warning system since I moved to XF 1.4 (in a language different than english) without issues.
  5. Gatses

    Gatses Member

    Need to change the language at the moment of issuance.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    It wasn't clear from your first post that you were manually changing the language.

    I took it to mean that it was changing automatically.

    I can now confirm the error.
  7. Gatses

    Gatses Member

    Sorry, I'm not very good with English. :)
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Don't worry about it, it's better than my Russian :)
    tonnyz, maszd, Daniel Hood and 3 others like this.
  9. Mike

    Mike XenForo Developer Staff Member

    This is a difficult issue and it actually does come up in a number of places. The issue is that we redirect you to dynamically back to where you came from. When you switch the language, this tracking gets interrupted so it tries to redirect you back to the warning page, which gives an error because there can only be one warning per piece of content.

    I have worked around this in this case though.
    Gatses likes this.

Share This Page