[TAC] Stop Human Spam

[TAC] Stop Human Spam [Paid] 1.4.8

No permission to buy ($19.00)

fion

Member
When I unzip the download, all the files are in one directory. There is no upload directory or directory structure.

I could manually upload each one to the previous file structure and change all of the file names I suppose. The current file names are like "stopHumanSpam\upload\library\Tac\StopHumanSpam\ControllerPublic\Member.php"
 

Yugensoft

Well-known member
When I unzip the download, all the files are in one directory. There is no upload directory or directory structure.

I could manually upload each one to the previous file structure and change all of the file names I suppose. The current file names are like "stopHumanSpam\upload\library\Tac\StopHumanSpam\ControllerPublic\Member.php"

Ah, that's Windows for you :rolleyes:. I'll fix it and let you know when it's uploaded.
 

fion

Member
Looks like it is in the correct format now. I will install and let you know if I run into any issues.

Thank you for your help.
 

fion

Member
I have discovered a problem that happens when an anonymous user (we allow anonymous posting on some boards) answers a captcha question incorrectly and the post contains a word in the TAC banned post content words list. When this happens, both the new post with the banned word in the content is put into the moderation queue and the most recent live post in the thread is pulled back into the moderation queue.

This used to happen with older versions when any post with a banned word in the content was put into the moderation queue. This no longer happens with the current version. It only happens when the captcha question (using the captcha question capability found under the options>basic board information settings) is answered incorrectly and a banned word is present.

The version of XF where this is occurring is 1.4.8.
 

fion

Member
Thank you. I found another issue. If someone starts a new thread that includes something in the banned words list then they get a error message that says "the requested thread could not be found". This happens even if they have answered the captcha question correctly.
 

SEOmers

Active member
Will this be moving to x2? This was very much apart of my forum purely because I could limit threads to a forum, only if they'ed posted say x in however many days. I miss it
 

Yugensoft

Well-known member
@fion could you send me the full error messages you see, if you get a admin error with stack trace, cheers.
But either way this will take some time to fix.
 
Last edited:

fion

Member
I installed v1.4.6 and did some initial testing. So far it looks like the problems are fixed. I will let you know if I find any issues.

Thank you for your help with this.
 

Alpha1

Well-known member
A url whitelist would be pretty neat to have.
There are a number of legit site that new members tend to post and cause false negatives. Having these whitelisted would save us from a lot of reports.
 

Yugensoft

Well-known member
Any kind of time limit when this would be ready for XF2?
Not at the moment, busy working on other more pressing things.
The issue with these TAC addons is that it's likely going to take outright rewrites (with perhaps taking a snippet or concept here or there from the XF1 version), to port their concepts over properly. So it's not going to be a brisk process.
 

Xon

Well-known member
In Tac_StopHumanSpam_ControllerPublic_Thread::addReplyResponse

Code:
            if(
                $responseView instanceof XenForo_ControllerResponse_Error ||
                $responseView instanceof XenForo_ControllerResponse_Exception ||
                $responseView->errorText
            ) {

This breaks if responseView is a redirect as it is unconditionally accessing errorText. wrapping in !empty() should fix that
 
Top