1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue SWFUpload Button Hides Insert Quote

Discussion in 'Resolved Bug Reports' started by ekool, Jul 31, 2014.

  1. ekool

    ekool Member

    Version: XenForo 1.3.3 - 1.3.4 (tested)
    Browser: Chrome (36.0.1985.125)
    OS: OSX 10.9.4

    I've noticed this on a few of our sites now and tested it on a default style as well as a custom style.

    When trying to create a new thread the button to "Create Thread" is hidden behind the "Upload a File" SWF layer. Also when trying to insert quotes into a reply post, the "Insert Quotes..." button is hidden behind the "Upload a File" SWF layer.

    I've found a fix for this is to change the style position of the SWF object from "position: block !important" to "position: inline-block !important", however I can't find where to actually make the change. The closest I get is in the file js/swfupload/swfupload.min.js where that object tag is being embedded, but seeing as it's minified, and using variables to set style attributes I haven't been able to track it further. (Looking in templates was a waste of time as the template uses a placeholder '<span id="SWFUploadPlaceHolder"></span>').

    I'm attaching screengrabs to illustrate. Although the screengrabs don't show the mouse pointer, whichever button is circled is the button being hovered over with the mouse. I also circle the CSS change which fixes it.

    I've noticed just now in uploading the screengrabs that the same behaviour happens on this create thread form as well. As a test I just enabled my flash control and it shows where the flash layer sits. I'm uploading that screngrab as well..
     

    Attached Files:

  2. Mike

    Mike XenForo Developer Staff Member

    This is actually caused by a browser add-on that you have installed. Let me see if I can find the previous report...
     
  3. Mike

    Mike XenForo Developer Staff Member

  4. ekool

    ekool Member

    Yep, I can confirm that.. If I completely disable Flash block as an extension not only does the issue go away, but I notice that style attribute with "block !important" also goes away.. The add-on must be adding that.

    Thanks Mike!
     

Share This Page