1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 sudden could not be found error - Use Full Friendly URLs - forum url only

Discussion in 'Troubleshooting and Problems' started by EvilSS, Nov 24, 2014.

  1. EvilSS

    EvilSS Member


    as of today, im not sure why this has suddenly happened. but when i try to access a forum URL i get an error saying "The requested page could not be found". this seems only to be effecting forum url's only as of like 30 minutes ago. this does not seem o effect thread urls, i can access threads but not forums.

    ive had "Use Full Friendly URLs" enabled for over a week with no issues, but as of 30 mins ago, accessing forum urls example: http://www.forum.com/baily-tent.5/ gives a "could not be found error".

    but when i disable "Use Full Friendly URLs" all comes good. again this has just suddenly happened with nothing new installed.

    client forum is istalled in root. this is .htaccess code:

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        # Redirect non-www to www
        RewriteCond %{HTTP_HOST} ^forum\.com [NC]
        RewriteRule (.*) http://www.forum.com/$1 [NC,QSA,L,R=301]
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    fyi: Index Page Route: is set at forums/
    hoping for a quick fix please?

    edit: added $config['enableListeners'] = false; to config, still errors.
    Last edited: Nov 24, 2014
  2. Brogan

    Brogan XenForo Moderator Staff Member

    If you haven't made any changes yourself, as the problem has suddenly started, you should contact your host and ask them what has changed on the server.
  3. EvilSS

    EvilSS Member

    i was thinking along those lines, but, all i did was change styles to default, then change back to forum style and the error was gone.

    thanks Brogan, if it does happen again, i maybe blaming a template edit, as im basically my host of my server and i didnt change a thing.
    the only templates that were edited over a few days ago was adding:

    <script src="/mediaelement/build/jquery.js"></script>
    <script src="/mediaelement/build/mediaelement-and-player.min.js"></script>
    <link rel="stylesheet" href="/mediaelement/build/mediaelementplayer.css" />
    to "PAGE_CONTAINER" template.

    and editing attached_files with a media code. which worked fine.

    would you think this would effect rewrite .htaccess?

    cheers and thanks for your support.

Share This Page