• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Successful import vB 4 to XF!

Morgain

Well-known member
#4
nice and sleek

good balanced but not boring logo.
bit of custom in appearance/ style properties
which is not hard

if you stick with xf standard it can confuse people with here.
 

Big Dan

Active member
#6
Ohh, no redirect for old discussions :eek: ... please do it
I tried, I really did. The instructions weren't very clear from the start. No matter what I did going to an old thread kicked me back to the homepage. Google will catch up with me I suppose; maybe I'll give it another go tomorrow.
 

Ingenious

Well-known member
#7
Well done, there's no turning back now :)

If by being kicked back to the homepage during a redirect, you mean clicking on a link on vB puts you to your Xenforo forum homepage, that's usually a sign the redirect scripts are not configured properly, for example, you have the wrong table name for the archived posts (it happened to me) in the config file.
 

Big Dan

Active member
#8
Well done, there's no turning back now :)

If by being kicked back to the homepage during a redirect, you mean clicking on a link on vB puts you to your Xenforo forum homepage, that's usually a sign the redirect scripts are not configured properly, for example, you have the wrong table name for the archived posts (it happened to me) in the config file.
Thanks Ingenious. That's what is happening. I defined my table 'vb4_import' in 301config.php but read later on a post that the vB 4 redirector plugin only supported the default table name 'archive_import_log'. It would've been nice if that was noted in the first post and I would've left the import with the default name.
 
#11
Thanks Ingenious. That's what is happening. I defined my table 'vb4_import' in 301config.php but read later on a post that the vB 4 redirector plugin only supported the default table name 'archive_import_log'. It would've been nice if that was noted in the first post and I would've left the import with the default name.
YOU SIR, ARE AWESOME. Sorry for the caps, but after looking around for ages not being able to sort that, renaming the table to xf_import_log has got my redirects working!

I'd rather not have all that data as the last import though so I'll try and change the vb4 redirect script to accommodate the 301config.php settings!

In the meantime, muchos thank you ever so much! :D

(PS: Congrats on the migration, you have a similar number of posts to the forum I just migrated! :))
 

Big Dan

Active member
#12
Thanks James. :) How'd you rename you're table through phpmyadmin? I'd really like to get the redirects working as Webmaster tools is showing a bunch of soft 404 errors.
 
#13
Open up the table, choose Operations, then there should be a 'rename table to' option (you might want to make sure there isn't a blank xf_import_log table that already exists)



James
 

Big Dan

Active member
#14
Open up the table, choose Operations, then there should be a 'rename table to' option (you might want to make sure there isn't a blank xf_import_log table that already exists)



James
YOU SIR ARE THE AWESOME ONE! :)

I was going to poke around but I don't like to poke around in phpmyadmin unless I really have to.