1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Style Chooser is having fits (multiple styles)

Discussion in 'Resolved Bug Reports' started by Elizabeth, Jan 14, 2011.

  1. Elizabeth

    Elizabeth Well-Known Member

    I was okay as long as I had no more than 2 styles, the one shipped with it and mine (Secret City Designs) the one in yellow.
    However, I have more styles to add so that users can download free styles to use from my site. They need to see them on my site as a demo. I had loaded two and decided to check to see how they were working. So I went to the style chooser:

    And picked Celebration as you can see...

    However, what I see is still the first image: Secret City Designs.
    I checked in Opera and it works fine. I've cleared my cache and it still doesn't help. Short of clearing out passwords, history, the entire nine yards which is something I really do not want to do each time I want to change styles, I don't know why it's holding onto it so hard. And it's not something I need my clients to have to do either.

    Any help? Or is Firefox just being a pill?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I just tested here and on my local install with Firefox and I don't get the problem you're reporting.

    Have you tried CTRL+F5, that normally resolves any issues with FF.
  3. Elizabeth

    Elizabeth Well-Known Member

    okay, no F5 on this keyboard, so I have to clear it using it thru Tools>Clear Recent History>Clear Cache.
  4. Elizabeth

    Elizabeth Well-Known Member

    I've gotten Firefox to refresh several times, it still won't budge off my personal default theme to allow for a different choice to view others.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    I'm not sure what to suggest.

    You say it works OK in other browsers and I can't reproduce the problem on 2 sites using Firefox.

    Presumably you're using the same account on each browser?
    It's not that you've forced that style?
  6. Elizabeth

    Elizabeth Well-Known Member

    Yes, I am using the same account in each browser to be fair. I checked to make sure I wasn't forcing the style...did that once before to myself. [​IMG]
  7. Brogan

    Brogan XenForo Moderator Staff Member

    FWIW, I just checked your site using FF, Chrome and IE and I was able to change the style in each one to check all styles.

    I would just try restarting Firefox and/or your computer.
  8. Elizabeth

    Elizabeth Well-Known Member

    Never mind, close this...must be something I have done to myself...
  9. Steve F

    Steve F Well-Known Member

    I get this also on my localhost. Clearing history, cache ect works ok for a while but the problem comes back. Trying to switch to any style just reloads the page and the style remains the same as before choosing to switch. If I log out I am able to switch styles without issues in all browsers I have installed, IE8, Chrome & FF.
  10. Dean

    Dean Well-Known Member

    This is causing me grief too.. 2 installs of xf, erratic behavior.

    edit: confirmed. At least on one test site, cannot select with ff, but can in chrome.. this has never happened before with xf.

    We are also working through some other things.
  11. Dean

    Dean Well-Known Member

    To be clear, we reverted the footer template which was outdated, and the issue still exists.. only in fire fox.

    Yes I cleared the cache, and did a hard re-fresh.

    EDIT: we only have 2 styles. Default, and custom style.
    Kaiser likes this.
  12. Kaiser

    Kaiser Well-Known Member

    I confirm this also... firefox only
  13. Mike

    Mike XenForo Developer Staff Member

    I'm taking a stab in the dark, but moving this to bugs to remind me to look at it. When changing the style as a logged in user, clear the style cookie.
  14. Dean

    Dean Well-Known Member

    That did it.

    Deleted the xf_style_id cookie which was set to 3. Now I can select the default skin. I changed back and forth several times and now it works fine..

  15. Miko

    Miko Well-Known Member

    Thank you for the "temporary solution"
    Logging out and then logging back in causes the same problem until manually deleting the xf_style_id cookie again.

    Weird things on my localhost is working fine.

    I'm using Firefox 4.0 Beta 8 on Mac OS X 10.6.6
  16. John

    John Well-Known Member

    Do any of you have debug mode on? I was having the same issues and corrected it when I disabled debug mode.
  17. Elizabeth

    Elizabeth Well-Known Member

    Not that I am aware of, John
  18. Miko

    Miko Well-Known Member

    Debug is turned on, on my localhost and it's working fine.

    My second test server with Debug turned off, it's not working.

    Opposite of your situation :p
  19. John

    John Well-Known Member

    Yeah, once I turned debug back on I was fine as well...without having to delete any cookies. Most odd :/
  20. Miko

    Miko Well-Known Member

    Very odd indeed, funny things on my localhost is working perfectly.
    For a moment I thought I messed something up when I upgraded my dev forum... I'm glad it wasn't my code!

Share This Page