Fixed Stop Forum Spam not working

akia

Well-known member
I've turned on the stop forum spam settings as in the picture:

upload_2013-7-12_20-58-27.png

but I've noticed that it dosn't seem to be working. I've had users register that when I've checked the IP manually on stop forum spam they are listed more than the settings above which should have triggered for them to be admin approved.

I've also spam cleaned a member and the details have not been submitted to Stop Forum Spam.
 

Brogan

XenForo moderator
Staff member
Perhaps the values in the SFS database were only updated after they registered.

When submitting data to SFS, it's up to them to update it in a timely manner.
Are you sure the data hasn't been received by them?
 

akia

Well-known member
it would also be better if there was a log kept, then at least its possible that check that its working.
 

akia

Well-known member
@Mike Theres something still wrong here.

I've got my settings as follows:

upload_2013-7-20_13-54-19.png

upload_2013-7-20_13-54-40.png

But I'm still getting members showing up for manual approval.

Also, I'm having members showing up for approval when they are not listed on stop forum spam at all. The last one I had I've checked the IP, Email and username and they don't show up at on the SFS database.
 

Mike

XenForo developer
Staff member
PM me all the details you have from that user - name, email, and IP at the least. I will need to attempt to reproduce it.
 

akia

Well-known member
@Mike, also to note, I've got "Moderate registrations when this many warning flags are detected" unticked along with "Check DNSBL on registration" unticked. So I shouldn't be getting any members to approve. It should be a simple they are blocked/not blocked. But they still keep appearing in the queue.
 

Mike

XenForo developer
Staff member
Looks like the code to disable thresholds was basically just ignored (meaning 0 points to trigger it). Fixed that now.
 
Top