1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Staff Can't See Staff Forum (Node Permissions)

Discussion in 'Troubleshooting and Problems' started by Calvert, Aug 1, 2011.

  1. Calvert

    Calvert Member

    How to reproduce:

    1. Create an account with the primary usergroup as Registered Users
    2. Make that account's secondary usergroup Moderators
    3. Set up a private forum called "Staff Forum", allowing only the moderator usergroup to view it under Applications > Node Permissions > Staff Forum > Moderators > View Node > Allow.
    4. You can additionally edit the specific account to allow the user to view the forum from under Applications > Node Permissions > Staff Forum using the field at the top right. (Bug reproduced both with and without this step).
    5. Log in as this user and you will notice that the account cannot view the private staff forum, despite being a moderator through the secondary account.

    However, if you make the account's primary usergroup as Moderator then you will be able to see the staff forum. Surely though, the account should still be able to view the forum by inheriting the moderator privileges from the secondary account.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I have my staff set up exactly like that and it works fine for me.

    In fact, the recommended way of setting up the user groups is to have all members in the Registered group as the primary, and any additional user groups are secondary.

    Do you have any add-ons installed?
     
  3. Calvert

    Calvert Member

    I have the following add-ons installed:

    I'll try and reproduce the bug one more time to confirm.

    Update: Yes, the moderator account can only view the forum if the primary usergroup is set to moderator instead of the secondary.
     
  4. Jeremy P

    Jeremy P Well-Known Member

    Works with secondary for me. You sure that the moderator's primary usergroup doesn't have permissions for that forum marked as "Revoked" or "Never" ?
     
  5. Carlos

    Carlos Well-Known Member

    I think the creating a private forum is confusing to me.

    So, I just went like "screw this." And left the feature alone.
     
  6. Kevin

    Kevin Well-Known Member

    Calvert, did you set the forum to be private? Here are the steps that have been working for me (I've been setting up multiple XF sites this week) for creating staff areas...
    1. Create a new category. For example, name it "Staff Area".
      • ACP => Applications => Create New Node => Category
      • Just give it a title and then save it.
    2. Make the new category private.
      • ACP => Users => Node Permissions => Click on "Staff Area" (or the name you gave it) => Check "Private Node" option
    3. Make the category viewable to your admins & moderators.
      • ACP => Users => Node Permissions => Click on "Staff Area" (or the name you gave it) => Click "Group Info" to the right of the "Administrative" user group name
      • Find the "View Node" listing, should be at or near the top, and turn on the "Allow" option (the green column)
      • Scroll down and "Update Permission" for the group
      • Repeat for the "Moderating" group.

    And that should be it. To test it, view the forums as a user would see the site.
    • ACP => Users => Test Permissions
      • Try it twice, once for a 'Registered' user who shouldn't see nor have access to the category and also again as a staff member (where their primary group is registered and then have a secondary group of Administrative or Moderating).
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Kevin's instructions are spot on.

    The beauty of the system is, if you make the top level category private, it also makes all child nodes under it private aswell.

    Similarly, when you grant specific groups view access to the top category, the child nodes also become visible.

    It's a very powerful and quick system for making whole sections visible to individual groups or members with just a few clicks.

    Regarding the original post, I have moved the thread from bug reports to troubleshooting as I am unable to replicate the issue and everyone else seems to have no problems with the function.
     
  8. Calvert

    Calvert Member

    It looks like I have finally sorted it. I followed Kevin's instructions although I didn't click "Group Info" as that edits permissions for the usergroup in general. Instead, I clicked on the group name on the left and it allowed me to specifically set permissions for that node. The default for "view" was set to "inherit". I changed it to "allow" and it seems to have worked. I'm not sure why that was causing a problem.
     
  9. Temery

    Temery Active Member

    Searching the forums before posting a question pays off. This answers perfectly the exact question I was about to post.

    Thanks
     

Share This Page