1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 SSL HTTPS Issues - Broken CSS

Discussion in 'Troubleshooting and Problems' started by Wesker, Sep 18, 2015.

  1. Wesker

    Wesker Active Member

    We're really stuck here on how to resolve this. We recently migrated to a new server. We have SSL installed correctly. Switching themes doesn't resolve the issue. However, this is what our site looks like in https://


    Any suggestions?
  2. nodle

    nodle Well-Known Member

    Did you enable image proxy? Goto ACP> Options> Messages> then turn on proxy images.

    EDIT* just notice 1.3 Don't know if this feature is in there or not.
    Last edited: Sep 18, 2015
    Wesker likes this.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    I can see blocked requests in the console due to mixed content errors.

    What do you have set for the board URL?
    Have you updated it to https?
    Wesker likes this.
  4. Mike

    Mike XenForo Developer Staff Member

    Are you using a proxy like CloudFlare? If so, is it connecting to your server via HTTPS?

    If you're not using a proxy, what web server are you using?
    Wesker likes this.
  5. Wesker

    Wesker Active Member

    Yes. However, due to caching issues we paused our performance with them

    Status: Paused
    Web traffic to this website is no longer receiving performance and security benefits. CloudFlare continues to resolve the DNS. You can reactivate CloudFlare for this website at anytime.

    The issue still remains
  6. Wesker

    Wesker Active Member

    Board URL
    Set to http://
  7. Wesker

    Wesker Active Member


    Image and Link Proxy

    • Proxy Images
    • Proxy Links
    • Proxy Thumbnails

    All of these are UNCHECKED.
  8. Steve F

    Steve F Well-Known Member

    That needs to be your full URL I would say with https

    Wesker and Glockie like this.
  9. Glockie

    Glockie Well-Known Member

  10. batpool52!

    batpool52! Well-Known Member

    Try adding this
    $_SERVER["HTTPS"] = "on";
    to config.php after
    Wesker and Glockie like this.
  11. Wesker

    Wesker Active Member

    This fixed it! I can't thank you enough batpool52!. Really really rough week but you made my

    Never got the chance to test this but this may as well. Thank you @Glockie

    Also thank you as well @Mike @Brogan @nodle
    batpool52! and Glockie like this.
  12. Wesker

    Wesker Active Member

    Guys now i have a more serious issue because the entire site is down

    This is the error I get now.

    400 Bad Request
    The plain HTTP request was sent to HTTPS portnginx/1.8.0
  13. Wesker

    Wesker Active Member

    I tried to remove this code

    Hasn't fixed the issue.

    I also noticed adding this code broke the ability to post prior to this.
  14. Wesker

    Wesker Active Member

    It's working now. Had to reboot the server.
  15. batpool52!

    batpool52! Well-Known Member

    Even this is fixed? or still occurring?
  16. Wesker

    Wesker Active Member

    - Added code to config.php
    - Started to notice site errors, specifically the ability to post stopped working
    - Removed your code from config.php
    - Post issue was resolved
    - 30 seconds later error occurred
    - Rebooted server
    - Error gone
    - HTTPS issue still remains
  17. Wesker

    Wesker Active Member

    This link: /admin.php?options/list/basicBoard

    Previous Board URL - http://

    New Board URL - https://

    The issue as of now still remains despite the change.
  18. Wesker

    Wesker Active Member

    Will add again that this did fix the CSS issue but it broke other parts of the site, specifically the ability to post replies.
  19. Wesker

    Wesker Active Member

    Shortly after making this adjustment, the site went down because of this issue

    400 Bad Request
    The plain HTTP request was sent to HTTPS portnginx/1.8.0

    Site is backup because I reverted the change back to http://. Same issue above when I made the change in config.php

    Looks like it did fix the issue in https:// but it broke the http:// with that 400 bad request error.

    Core issue here is making any of these requested changes above from http:// to https:// seems to result in a 400 bad request above.
  20. Wesker

    Wesker Active Member

    I will repeat what @Steve F @Glockie @batpool52! mentioned to do in the early morning (traffic drops). We have fixed the 400 bad request issues but I think we just need time to adjust the conf file.

Share This Page