1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Some images showing as attachments, not thumbnails

Discussion in 'XenForo Questions and Support' started by cmeinck, Apr 29, 2011.

  1. cmeinck

    cmeinck Well-Known Member

    I've created a test thread on my forums, where I uploaded five images and inserted them all as thumbnails. On my site, some thumbnails show up, but some show up as attachments. They are all .png files. When I do the same test with the same images here at XF, they all show up as thumbnails (as they should).

    These are my Options > Attachments settings.

    Screen shot 2011-04-29 at 10.31.55 AM.png

    Suggestions?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Try removing the advert from the post body and see if that has any effect.
     
  3. cmeinck

    cmeinck Well-Known Member

    I reverted the ad_message_body and tried again. The same result. It seems the .png files are showing up as attached. The .jpgs work fine.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any add-ons installed or have you made any modifications to any of the core (php) files?

    I just did some quick tests with a few installations (custom and vanilla) and I couldn't reproduce the problem.
     
  5. cmeinck

    cmeinck Well-Known Member

    I have a similar forum setup, where images work. There were a few add-ons that were not installed on the other forum. I uninstalled them and still no luck.

    Will rebuilding caches have any affect?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Are both forums on the same server?

    You could try uploading the files from the upgrade package again.
    It's possible that may help.
     
  7. Mike

    Mike XenForo Developer Staff Member

    The linked thread doesn't exist any more, so I can't see what the issue was...
     
  8. cmeinck

    cmeinck Well-Known Member

    Here's a new thread. Odd, because one .png is showing up.

    I'm creating these threads in the stock, unmodified XenForo template.
     
  9. Mike

    Mike XenForo Developer Staff Member

    I see 2 images in the body of the message, and one as a separate attachment. If an attachment isn't referenced in the body, it will be shown below. If you edit the contents of that post, you should only see 2 attachments in the actual post.

    The only way to really get more information would be to see a video of the post being created, as from what I see, I don't see anything wrong.
     
  10. cmeinck

    cmeinck Well-Known Member

    I've overwrote my files, disabled XFOptimize (figuring that *might* be the issue). Tried changing my ./js back to local (from CDN). Still, no luck. The other Add-Ons I have seem harmless and don't affect other sites with exact same configuration. (MailChimp, ragtek New User Conversation, TapaTalk, XenUtiles)

    Here's a video detailing what's happening.

     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Hmm, very strange.

    Has this ever worked?
    You mentioned earlier that it works on your other forum. Are they both on the same server?
     
  12. cmeinck

    cmeinck Well-Known Member

    Yes, it's worked on my test install and a beta before that. Both have since been removed. Here's an interesting twist. It works in Chrome, but does not in Safari 5.04 for Mac.

    This is on a different server than my other forums.
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Aha, so it's looking like it's browser specific?
    How about Firefox and IE?
     
  14. cmeinck

    cmeinck Well-Known Member

    It's real odd. I tried Safari on my laptop and no problem. I reset Safari, deleted the PLIST and ran a permissions fix on the drive. Same problem. I set javascript in performance back to ./js and now it's working. I thought I had tried that before with a different result. Guessing Safari had an issue with the javascript loading from CDN or my CDN settings were incorrect. However, javascript was working with my CDN. It was just the loading of thumbnail display when using Safari didn't work properly. Maddening for sure. For now, I'll keep ./js and revisit it.

    Thanks for your help.
     
  15. cmeinck

    cmeinck Well-Known Member

    As a postscript, the Twitter share button also had a display of 2 (which I knew was incorrect). Now it's back up to 20.
     

Share This Page