1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 [solved] Importing of attachments from vB4 fails with 500 server error

Discussion in 'Installation, Upgrade, and Import Support' started by PyroM, Aug 1, 2013.

  1. PyroM

    PyroM Active Member

    I did several test migrations from vB 4.2.1 (upgraded from vB3.7) and all worked fine till now. For the xf1.2 betas I used the add-on http://xenforo.com/community/resources/vb4-importer.1025/, with xf1.2rc2 I tried both: first with the new core vB4 importer, later again with the add-on (because of the Post Thank You import option) in a fresh xf1.2rc2 installation. In all cases I could import everything including the 1.1 GB of attachments from the vB directory in file system.

    With release 1.2.0 this is not possible anymore. Both importers fail when choosing the attachment option. I do immediatly get a 500 server error, no attachments are imported. For these tests I always use blank installations of xf1.2.0 with clean and healthy file system and fresh database. Trying to use the core importer is 100% without any add-on installed or any other setting/modification. For the add-on importer this is the only add-on installed, overwriting the vbulletin.php in importer library.

    I can reproduce that importing attachments still works in beta3 (add-on) and it does not work in release 1.2.0 (core or add-on) anymore. I deleted my zip of 1.2rc2 too early, so I cannot try that again, but I am pretty sure it worked, both ways.

    Its happening on a local test system, cannot try on Linux server at the moment:

    Win 64Bit Home Premium
    500k posts
    1.1 GB attachments in file system in vB4 folder
    Apache 2.2.11
    PHP 5.3.5
    MySQL 5.5.8

    What am I doing wrong, please?
    There is no entry in the server log of xf...
  2. Mike

    Mike XenForo Developer Staff Member

  3. PyroM

    PyroM Active Member

    Ahhhh, I searched before opening this thread but did not find that.
    Yes, it seems to solve the problem, tried with core importer first, no 500 error, attachments are being imported right now.

    Thank you, Mike!

Share This Page