1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 [Solved] Can't reply topics and can't select posts

Discussion in 'Troubleshooting and Problems' started by Recep Baltaş, Aug 26, 2015.

  1. Recep Baltaş

    Recep Baltaş Well-Known Member

    After moving the server, we can not select posts. And on some topics, reply area does not appear.

    xenforo problem.jpg

    We are behind CloudFlare. Could this be the problem ?
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Could be cloudflare. There's a number of things they can do to the JS in the page output, including compression.

    Rocket script is one of the common things that causes problems I think.
     
    Recep Baltaş likes this.
  3. Recep Baltaş

    Recep Baltaş Well-Known Member

    Oh man you are a savior! Fixed!

    Disabled Rocket Loader.
     
    Chris D likes this.
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Rocket Loader needs to be renamed to Rocket expLoader. It's caused issues for years - you can do some exclusions, but it still rears it's ugly head.
     
    Recep Baltaş likes this.
  5. TheXboxCloud

    TheXboxCloud Active Member

    Cloudflare also causes a number of caching issues.

    I suggest making a page rule with the cache on "bypass cache" or off along with disabling rocket loader.

    You will find images do not always appear and ftp uploads may not appear always either. I had this issue with my site and once making a page rule I never had a problem again.
     
    Recep Baltaş likes this.

Share This Page