1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Solved - An unexpected error occurred. Please try again later.

Discussion in 'Troubleshooting and Problems' started by ElgrandOC, Aug 5, 2016.

  1. ElgrandOC

    ElgrandOC Member

    Right, so I went to bed last nifht and everything was working. Woke up this morning and when I try to get onto my forum, I get this

    "An unexpected error occurred. Please try again later."

    I've not done anything to any settings. I've checked the server error log, and nothing. I've checked the forum error log, nothing since 27th July.

    I have asked the host and no changes have been made in the background any settings on the servers.

    Does anyone have any advice on what I should do now?

    Edit: forgot link http://forum.elgrandoc.uk
     
    Last edited: Aug 5, 2016
  2. whynot

    whynot Well-Known Member

    Your forum seems has been hacked:

    You have to clean up the mess.
     
  3. Chris D

    Chris D XenForo Developer Staff Member

    That could be a false positive, that sometimes happens.

    It would be interesting to know what the "detailed report" says. If something happened ovenight, it's highly unlikely Norton will have picked it up and started blacklisting it already.
     
  4. Mike

    Mike XenForo Developer Staff Member

    If you access the installer, it appears that your host has enabled safe_mode, which XenForo actually requires being off.

    That said, you may be able to temporarily workaround it by disabling the file cache.
     
  5. ElgrandOC

    ElgrandOC Member

    OK, that Norton warning definitely looks like a hack. How can I even start to clean up the mess? Not dealt with anything like this before.
     
  6. ElgrandOC

    ElgrandOC Member

    @Mike, if safe_mode is on, then it was done before last night as I checked with my host and nothing was done at all to any settings last night.
     
  7. ElgrandOC

    ElgrandOC Member

    Will reinstalling the latest update resolve the problem by reverting any changes to the code?
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    Well, first step is to switch safe mode off, regardless. Whether it was already on or not, that should be eliminated. It's worth noting Mike's point, however, that the specific error on the install page suggests that the back end file caching is currently triggering the safe mode restriction error, so you may be able to disable that (in config.php) and that might be a workaround to get the site up and running.

    As I stated earlier, the Norton thing is actually more likely to be a false positive than anything so I wouldn't worry about that, yet. Focus on getting the site up and running first.

    You could try re-uploading the files from the current version you have installed (1.5.8), but I don't think that will make a difference while safe mode is enabled.
     
  9. Mike

    Mike XenForo Developer Staff Member

    An initial step would be to disable the file cache that you have configured in config.php. It appears to be what's causing this error. (Go to <url>/install/ and you'll see an error message.)

    However, safe_mode is a blocker to XenForo installation, so that would have to be disabled. Note that safe_mode doesn't even exist in PHP 5.4+. Presumably you're running PHP 5.3, which hasn't been a supported PHP release since 2014 (http://php.net/supported-versions.php) so upgrading would be a good idea anyway (and would resolve the safe_mode issue).
     
  10. ElgrandOC

    ElgrandOC Member

    What do I need to change in config.php to resolve the issue? Am I looking in the right place?

    /public_html/forum/library/Zend/config.php
     
  11. Mike

    Mike XenForo Developer Staff Member

    No, it's the library/config.php file. There's no external caching used out of the box, so this is something that you would have had to explicitly add to/enable in the file.
     
  12. ElgrandOC

    ElgrandOC Member

    You absolute legends. Thank you massively for your help. It's up and running again now.

    I'll leave that set to false (think I turned it on the other day, so took a while to trigger an error).

    Top level customer support right there. Thank you.
     

Share This Page