• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
[SolidMean] ForumBackup

[SolidMean] ForumBackup 1.2.01

No permission to download

SneakyDave

Well-known member
There should be an actual debug file that ends in .log in your backup directory. Take a look at the last 100 lines or so of that, and it should indicate the error. If not, send it to me in a conversation.

Turning the debug on in the add-on won't fix anything, it just logs processes that are taking place
 
Can you remove the 100 backup cap? I keep backups for over a year. Also, can you allow bzip2 compression? I changed the bin path to /usr/bin/lbzip2 and it works just fine for code backups but spits out error logs which show up in the admin panel.

DB backups still show .gz extension even thought they're bz2 but no error messages in log. Prob have the output hardcoded to *.gz ?
 
Last edited:

Nirjonadda

Well-known member
I am get forumbackup_2017-08-30-000200.sql.gz files only 20 bytes. Also get error in server log. Please let me know that how to fix mysqldump: Got error: 1045: Access denied for user?

Code:
[30-Aug-2017 02:02:00] WARNING: [pool mysite_com] child 13234 said into stderr: "mysqldump: Got error: 1045: Access denied for user 'user'@'localhost' (using password: YES) when trying to connect"
 

SneakyDave

Well-known member
@SneakyDave When happen the XF2 update? Also Please let me know that this add-on database table name?
As far as a XenForo 2.x update, I don't have any plans to convert this add-on at the moment. That might change in the future. I think the addon needs to be rewritten as a cron to prevent a lot of issues that creep up with shared hosting.

That being said, the code is available for anybody to use on GitHub:
https://github.com/SneakyDave/xfForumBackup

I just haven't had time to devote much, if any time, moving my addons to XF2.
 

Nirjonadda

Well-known member
As far as a XenForo 2.x update, I don't have any plans to convert this add-on at the moment. That might change in the future. I think the addon needs to be rewritten as a cron to prevent a lot of issues that creep up with shared hosting.

That being said, the code is available for anybody to use on GitHub:
https://github.com/SneakyDave/xfForumBackup

I just haven't had time to devote much, if any time, moving my addons to XF2.
Then Please let me know that this add-on database table name?
 

Floyd R Turbo

Well-known member

Sam F

Active member
Hi Dave

I just updated to the new version

looking at my backup file size, I noticed that they are a lot smaller.

Does it look like everything is backing up correctly?

Thanks

1514966899247.png
 

SneakyDave

Well-known member
You'd have to unzip those backups and compare them to see what the difference is between them

Something seems amiss tnough, Because you have a .tar file which should have been compressed to a .tar.gz file.

I would run the backup with the debug option on and then look at the debug file to see if it's failing
 

Sam F

Active member
You'd have to unzip those backups and compare them to see what the difference is between them

Something seems amiss tnough, Because you have a .tar file which should have been compressed to a .tar.gz file.

I would run the backup with the debug option on and then look at the debug file to see if it's failing
Backup CODE is now timing out?

do you think I should install the older backup version?
 

SneakyDave

Well-known member
I don't think using the older version will solve your problem. If you're on shared hosting, you may have issues with it timing out. You'd need to talk to your host about that.

I don't know what version you used to have, but if you revert back to it, you should always check to make sure that the backup is completing.
 

SneakyDave

Well-known member
Not sure what you mean by this, doesn't it run by cron already?
It runs in XenForo's cron, yes. I was talking about running it from a server's cron function. This backup solution fails on a number of shared hosting platforms due to how long the backup process can run. It's better suited for VPS systems that can run server level crons and adjust time out parameters.
 

Sam F

Active member
I don't think using the older version will solve your problem. If you're on shared hosting, you may have issues with it timing out. You'd need to talk to your host about that.

I don't know what version you used to have, but if you revert back to it, you should always check to make sure that the backup is completing.
Dave, I been using SolidMeanForumBackup-1.1.8 for two years and no problems, when I updated last night, this started to happen.

What do I ask the host? HostGator

Thanks