1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed soft hyphen

Discussion in 'Resolved Bug Reports' started by Markus, Nov 12, 2011.

  1. Markus

    Markus Member

    Invisible character in a thread title
    One of my members just posted a thread with an invisible character, we are running XenForo 1.1.0 Beta 5 Released.
    The thread was impossible to access without modifying the thread title to something clickable.
    Once I asked about this from him, he told me the following.

    Thread title was one character -> http://encyclopediadramatica.ch/Alt-0173
    Thread message was a mere [QUOTE tag][/QUOTE tag]

    Perhaps something should be done to this to prevent it from happening in the future.
     
    dieketzer likes this.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Shouldn't be too hard to fix that.
     
    ShadyX and Markus like this.
  3. Vincent

    Vincent Well-Known Member

    Title and picture say enough :D

    openbugreports.png
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    That's the bug....

    The bug is it's possible to post a title using an invisible character.
     
  5. Vincent

    Vincent Well-Known Member

    Ohh I just noticed it's a duplicate :D
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Merged with the original thread.
     
    Vincent likes this.
  7. Mike

    Mike XenForo Developer Staff Member

    The character is a soft hyphen. I'm going to start removing it as it is a very rare character, though it has some potential uses.

    I should note that in terms of a general purpose thing, there are lots of characters that can cause this and have valid uses, so we can't necessarily strip them out ourselves. You can always get into the thread via any date displayed in the row or you can click edit to change the title on the thread list.
     

Share This Page