1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue Smileys don't work : Android / Chrome

Discussion in 'Resolved Bug Reports' started by Rob, Apr 25, 2015.

  1. Rob

    Rob Well-Known Member


    I'm running Android 4.4.4 and using Chrome 42.

    When I click the Smiley in the editor to open the list of smileys and then click on a smiley, it does insert it into the editor.

    However, once you post the reply the smiley isn't there it's gone.

    This happens right here on Xenforo.com
  2. MattW

    MattW Well-Known Member

  3. Liam W

    Liam W Well-Known Member

    Testing: :)


  4. MattW

    MattW Well-Known Member


    New test

    EDIT: My phone has just updated to Android 5.0.2, but on the previous version (Xperia Z3), smilies were blank when inserted.
  5. Martok

    Martok Well-Known Member

    It worked for me. :)

    However, I've always had an issue with adding smilies on my Sony Xperia devices. If I try adding them and word prediction is enabled on my Xperia keyboard, the smiley is immediately removed after adding it. The workaround has been to add the smiley using the smiley code or to disable word prediction.
  6. Rob

    Rob Well-Known Member

    I'm on xperia device. It's not word prediction because the smiley is actually inserted in-line, at the cursor within the editor but it's not there when saving.
  7. Martok

    Martok Well-Known Member

    Mine inserts and then immediately removes the smiley and I see obj in the text prediction.

  8. Daniel Hood

    Daniel Hood Well-Known Member


    Mine worked.
    Samsung note3
  9. imthebest

    imthebest Formerly Super120

    Testing on Chrome (latest stable) on Android 4.4.2 in Note 3.

    Smiley: :sneaky:
  10. Rob

    Rob Well-Known Member

    Actually, yes I see the same issue regards OBJ. Its a PITA as there are loads of xperia devices, very common.
  11. MattW

    MattW Well-Known Member

    This is exactly what I was having before the phone updated.
  12. Rob

    Rob Well-Known Member

    I have a lollipop update to apply soon.... hopefully that fixes it - I'll report back.
    MattW likes this.
  13. Martok

    Martok Well-Known Member

    I've not installed my update as it's Lollipop 5.1 which has a memory leak bug. Waiting for 5.1.1 which is supposed to fix it.
    Rob likes this.
  14. Mike

    Mike XenForo Developer Staff Member

    Is that keyboard Sony/Xperia specific? That may be related.

    I can't reproduce this on a Nexus 5 running 5.1, either with the standard keyboard or SwiftKey. It sounds like this is specific to the Xperia line. Can you confirm with a different keyboard?
  15. Martok

    Martok Well-Known Member

    In my case, yes it is a specific Xperia keyboard. I do believe it's an issue with the keyboard and by the looks of it it's fixed in the next Android update on Xperia going by some posts above.

    I've not reported this before as I didn't think this was a XenForo issue. I was only responding to the OP to say that I could get smilies to work (albeit by typing in the smiley code) and to point out my issues relating to the keyboard. It appears that the OP is also using an Xperia device and no-one else in the thread using other devices is having the issue. So I'd say that this is a device/keyboard issue that is resolved with the latest firmware update. I'll be waiting for Android 5.1.1 though as that's supposed to have the memory leak fixed. :)
  16. Rob

    Rob Well-Known Member

    I am definitely convinced it is keyboard / xperia specific as non of my other android devices have this issue. I too am waiting for 5.1.1 release in order to upgrade and I'll confirm this is resolved then. Thanks for looking at this though Mike.
  17. Liam W

    Liam W Well-Known Member

    Do any of you people affected have rooted affected devices?

    If so, could you upload the APK for the IME included to see if I can test it?

  18. Rob

    Rob Well-Known Member

  19. Mike

    Mike XenForo Developer Staff Member

    I'm going to call this a keyboard/OS-customization issue then. (I don't think there's anything we really could do about it anyway.)
    Rob likes this.

Share This Page