XF 2.1 Setting Up Facebook Application

Alfuzzy

Active member
Hello,

I'm setting up the Facebook application for my site...and I'm following the "Creating a Facebook application" instructions from the Xenforo 2 manual. I've gotten to the point where I'm "Testing the connected account"...and I'm getting the following error:

Screen Shot 2021-05-27 at 1.12.28 PM.png

In the Facebook application account area...both Client OAuth Login & Web OAuth Login are set to "Yes"...and the "OAuth redirect URI" is exactly the same as it is in the "Basic board information" > "Board URL" in the XF AdminCP.

Screen Shot 2021-05-27 at 1.32.01 PM.png

Not sure if it's important...but have tried with & without www in the URL. Both ways I get the error.

Kind of confused where the issue is,

Thanks
 

Alfuzzy

Active member
Wow...not sure what happened but I got it working (passed the test). Originally I manually typed in the "Valid OAuth Redirect URI" (multiple attempts)...and the Connected Provider Test failed. Then I tried copying & pasting the board URL shown in the XF AdminCP "Test Provider" window...and it worked when tested.

The two were exactly the same. Very confusing that the copied & pasted URL from the AdminCP worked...but manually typing it in did not.

Still one question. When & where does the Facebook icon show up? I cleared the browser cache for the website...and refreshed the home page...but no Facebook icon.

Thanks
 

Alfuzzy

Active member
Hi Brogan,

I was expecting it to be something similar to one of the Facebook icon's in the left corner of the Xenforo.com footer area. Maybe I was mistaken.

One of these two:

Screen Shot 2021-05-27 at 6.52.37 PM.png

Thanks

p.s. I do see it on the register page.
 

Brogan

XenForo moderator
Staff member
Those are share icons and custom added social media icons respectively.

The registration icons appear in the log in and registration pages.
 

Alfuzzy

Active member
Those are share icons and custom added social media icons respectively.

Just to confirm. Are you saying both of the circled share icons in the screenshot are both via add-on products or custom work?

The registration icons appear in the log in and registration pages.

Ok I see. I was mistaken what I was expecting. I think I was expecting a share icon. But the registration icon is helpful too.

Thanks
 
Top