1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Server Did Not Respond in time

Discussion in 'Troubleshooting and Problems' started by SneakyDave, Dec 31, 2011.

  1. SneakyDave

    SneakyDave Well-Known Member

    I've seen this error just a few times on my site, normally using IE 8. Low traffic, no server error logs. Nothing in munin to indicate CPU, database, or memory issues.

    I've got it just logging into the admin section, and users have received it liking a post. Is there anything that can be done to try to pinpoint this problem?
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    For reference, I remember you posted in another thread about this:


    You were unable to reproduce the problem with likes.

    Is the error consistent? Does it happen every time? If it's intermittent then it's probably just an unreliable connection.
  3. SneakyDave

    SneakyDave Well-Known Member

    I've had it reported 3 times in the last month, I've seen it twice. Not consistent at all. I just wish those types of errors good be logged so that a possible pattern or time of day could be found. Nothing in nginx logs, nothing in slow_query_log, nothing in php error log, or xenforo server logs.
  4. Mike

    Mike XenForo Developer Staff Member

    There really isn't anything that can be logged - it's a client side error. It sent the request off but didn't get a response in time (30 seconds). If there's no web server log that corresponds to this, then the request likely never got there, which would indicate a connectivity problem for that person.
  5. SneakyDave

    SneakyDave Well-Known Member

    Well, that's weird, because I realize that javascript has a 30 second timeout, but it never takes that long to display the error.
  6. Mike

    Mike XenForo Developer Staff Member

    Something like a DNS error or an actual connection refusal (by the server or intermediate routing) would cause that. In situations like that, XF isn't even being hit.
  7. SneakyDave

    SneakyDave Well-Known Member

    Yes, I've seen some issues with that, thanks for the explanation. I think it's related to the Google Chrome issues I'm having.
  8. digitalpoint

    digitalpoint Well-Known Member

    It could also be certain services that XenForo uses that require connecting. For example on my test board, I set the mail server IP to something stupid (, and anytime XF would try to send mail I would end up with the "server failed to respond" message... because ultimately when it was trying to connect to "my" mail server at, it would wait longer than 30 seconds.

    It's actually one of the reasons I made an addon to send mail on shutdown vs. in realtime (the end user doesn't care if there really is a mail server issue with the *actual* mail server... and nothing they can do about it even if there is). Plus it makes the pages load faster since rendering time isn't dependent on mail being sent.
  9. SneakyDave

    SneakyDave Well-Known Member

    Is that add on available to try out?

    Thanks for that, I had seen some postings regarding misconfigured mail and the error, but it appears mail problems would throw something into the log file. I might try switching to SMTP to deliver mail just to rule that out. I think there was a mention about SMTP possibly slowing things down a bit due to it being synchronous, but I'm not running a lot of traffic at the moment. It's just something that's been nagging me that I haven't been able to figure out.
  10. digitalpoint

    digitalpoint Well-Known Member

    No, I haven't had time to wrap it up into something installable yet... But have you tried using the normal "Default" mail transport (sends it locally instead of making a network connection for mail sending)?
  11. SneakyDave

    SneakyDave Well-Known Member

    Yes, that's what I'm doing now, just because it's simple, quick, and asynchronous. I'm using the -f parameters, and haven't noticed any problems. I have noticed some mail being marked as spam though, but that's just because of a bad SPF record, or potentially other reasons. I haven't decided if a "no-reply@reverseDNSname" is better than trying to use something more recognizable or not, but that's a different thread.
  12. SneakyDave

    SneakyDave Well-Known Member

    As an update, a lot of my problems with connection, wierd Chrome errors, probably 90% of the errors I saw were resolved when I moved off Cloud Flare.

    From my Windows machine, I couldn't even traceroute to any site on the CloudFlare network, although most times I could browse the site without too many problems. CloudFlare told me that the problem was due to my ISP doing something with ICMP traffic. I could do traceroutes to sites on CloudFlare in Linux (UDP), but not Windows (ICMP).

    Even when I instituted the CloudFlare beta of "page rules", I had the same problem. It wasn't until I changed the name servers from CloudFlare to my original name servers did the problem go away.

    CloudFlare support admitted that it was having some problems with Xenforo installations, and that's when they tried to get me to try out the "page rules" route, which still didn't work.

    Personally, I think the problem lies in CloudFlare's DNS or how traffic is routed, or perhaps the way cached content is retrieved, but since I moved off that network, I've really had a lot better reliability.

Share This Page