• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Category Creation Error: Server did not respond in Time

Kainzo

Active member
#1

Other times..
The following error occurred

The server responded with an error. The error message is in the JavaScript console.


I'm getting this error message and it appears to only happen when I'm creating categories|forums.

I've attempted to disable the email option but has no change - I'm unable to remove all addons at this time (and when I tried, Xenporta would time out on the remove.

Any thoughts?

XenForo.activate(
  1. #document
)
xenforo.js:5​
Title Element:
d.fn.d.init[1]
xenforo.js:10​
XenForo.init() 27ms. jQuery 1.5.2/1.2.6-dev
xenforo.js:5​
Failed to load resource
http://www.google-analytics.com/ga.js​
setTimeout title
xenforo.js:10​
title: Okay
xenforo.js:10​
setTimeout display_order
xenforo.js:10​
display_order: Okay
xenforo.js:10​

Abort pending field validation...
xenforo.js:10​
Clear field validation timeout: title
xenforo.js:10​
Clear field validation timeout: display_order
xenforo.js:10​
Abort field validation request: title
xenforo.js:10​
Abort field validation request: display_order
xenforo.js:10​
  1. PHP Fatal error: Maximum execution time of 15 seconds exceeded in /var/www/vhosts/herocraftonline.com/httpdocs/main/library/XenForo/Model/Permission.php on line 1683
    xenforo.js:5​

XenForo.activate(
d.fn.d.init[1]
)
 

Kainzo

Active member
#3
PHP Fatal error: Maximum execution time of 15 seconds exceeded in /var/www/vhosts/herocraftonline.com/httpdocs/main/library/XenForo/Model/Permission.php on line 1683
 

Kainzo

Active member
#4
How many nodes / categories do you currently have? Do you also have a lot of user groups?
I have a plethora of both.

I'd say about... 60 forums (5 categories) and about 20 usergroups. I think this is a permission issue just not sure how to fix it.
 

MattW

Well-known member
#5
PHP Fatal error: Maximum execution time of 15 seconds exceeded in /var/www/vhosts/herocraftonline.com/httpdocs/main/library/XenForo/Model/Permission.php on line 1683
You need to make a change to your php.ini settings to increase the allowed execution time on PHP

increase the setting and restart apache

max_execution_time = XX (where XX is number of seconds)
 

Kainzo

Active member
#7
You need to make a change to your php.ini settings to increase the allowed execution time on PHP

increase the setting and restart apache

max_execution_time = XX (where XX is number of seconds)
That worked, how can i cut down on the permission loads? :(
 

Jake Bunce

XenForo moderator
Staff member
#8
That worked, how can i cut down on the permission loads? :(
XenForo does extra processing at save time to maximize performance at run time. It's a good trade, but in the case of node creation it can be intensive if you have a lot of nodes / usergroups. You can speed up the save by deleting any excess nodes / usergroups you don't use.
 

Kainzo

Active member
#9
XenForo does extra processing at save time to maximize performance at run time. It's a good trade, but in the case of node creation it can be intensive if you have a lot of nodes / usergroups. You can speed up the save by deleting any excess nodes / usergroups you don't use.
Good to know, at the moment we use all of them. Someone mentioned that we can use sub-groups to be less intensive but I havent seen anything about that yet...