• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 RSS -> author array must include a... Error

Chris D

XenForo developer
Staff member
#2
Can you provide some more details?

You've prefixed the thread with XF 1.4 but what version specifically? (Though I think there was a bug fixed in a much older XF version that was fixed before 1.4).

When does this happen? Is it just logged in the error log? Or when visiting a certain page? Are there any other details, such as a stack trace?
 
#3
version is XenForo 1.4.7
no Addons
error log is clean as far apart from these messages

Stack trace:
Code:
Zend_Feed_Exception: Invalid parameter: author array must include a "name" key with a non-empty string value - library/Zend/Feed/Writer/Entry.php:92
Generiert durch: testuser, Vor einer Minute
Stapelverfolgung
#0 /var/web/domain1/html/library/XenForo/ViewPublic/Forum/View.php(76): Zend_Feed_Writer_Entry->addAuthor(Array)
#1 /var/web/domain1/html/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Forum_View->renderRss()
#2 /var/web/domain1/html/library/XenForo/ViewRenderer/Rss.php(31): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Rss', Array, 'forum_view')
#3 /var/web/domain1/html/library/XenForo/FrontController.php(586): XenForo_ViewRenderer_Rss->renderView('XenForo_ViewPub...', Array, 'forum_view', NULL)
#4 /var/web/domain1/html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_Rss), Array)
#5 /var/web/domain1/html/index.php(13): XenForo_FrontController->run()
#6 {main}
Benötigter Status
array(3) {
  ["url"] => string(73) "http://www.domain1.com/forum/test-thread.1139/index.rss"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Mike

XenForo developer
Staff member
#4
Based on your previous message, I assume you imported? Did you use the big board importer? If so, it has imported some invalid data. That forum (domain1.com/forum/test-thread.1139/) likely includes a thread with no name for the thread starter. It would have to be removed (or data edited in the DB directly).
 
#5
I had in VB probably some faulty threads (without posts) have been imported and then made worse. Also the User Info missing in the Thread

thanks!