1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Romanize url option

Discussion in 'Troubleshooting and Problems' started by Pierre Boulanger, Sep 25, 2014.

  1. Pierre Boulanger

    Pierre Boulanger Active Member

    I'm facing an issue with this option. When I create a thread in Greek the "romanization" is completely changing the meaning of the respective url.

    This situation creates a serious problem in my forums site map and in google search engines. I have 2 licenses and I really wonder why after all these updates you are not implementing the custom url option.

    I need some help please. You may move this post to the proper forum if needed. I must find a solution
     
  2. Mike

    Mike XenForo Developer Staff Member

    Romanization in general can't be perfect -- languages that don't use Latin characters don't inherently map 1:1. The transliteration was done using Greeklish as described here if I recall: http://en.wikipedia.org/wiki/Romanization_of_Greek

    Can you explain what problem you're having?

    If the Romanization doesn't work for your needs, I would probably recommend not enabling it; URLs can have UTF-8 encoded in the and it will work correctly.
     
  3. Pierre Boulanger

    Pierre Boulanger Active Member

    When I see my forums site map all the romanized links are wrong. If i had the chance to edit them before posting a new thread, even using pure Greek and not Greeklish wouldn't be better for search engines? O bought my first license before 15 months and still most of the topics - discussions have not been listed in google. Others using international terms are just fine. Is it so difficult to add this option?


    Even in WP that i also use this option exists by default
    2014-09-25  WordPress.png
     
  4. Mike

    Mike XenForo Developer Staff Member

    If you're not being listed in Google, that won't be related to your URLs. That would likely be related to Google not accessing your data (or being able to access your data). You should use the webmaster tools to give you a better idea of what's going on and what it's doing with your sitemaps.

    You haven't really explained what's "wrong". You can see from that link that there are various ways to romanize Greek, so it may just be that you have different preferences in the romanization. In that case, you would need to edit the code to suit your needs. If you want pure Greek in the URLs, then you should just disable romanization.

    XenForo and WP are very different targets and use cases. If you really want to customize specific URLs though, you can look at using route filters to change them.
     
  5. Pierre Boulanger

    Pierre Boulanger Active Member

    What link?
    If I disable romanization the links are like this:
    http://my2cv.gr/forum/threads/citroen-2cv-ανακατασκευή.1162/
    If you have more info on how I can do this please advice
    I'm using webmasters tools and the site is verified. But when I'm checking the site map through webmasters all forum links are in romanize and what i would like to know is if the bad Greeklish transliteration effect the correct indexing in search engines.

    Example:

    There is a thread "Citroen 2cv ανακατασκευή" which means Citroen 2cv restoration
    With romanization turned on the link is:
    http://my2cv.gr/forum/threads/citroen-2cv-anakataskey.1162/

    The correct Greeklish should be:
    http://my2cv.gr/forum/threads/citroen-2cv-anakataskevi.1162/

    With romanization turned off the link is:
    of a legend.png

    Which is great but when i paste it in various sites looks like this:

    Code:
    http://my2cv.gr/forum/threads/citroen-2cv-%CE%B1%CE%BD%CE%B1%CE%BA%CE%B1%CF%84%CE%B1%CF%83%CE%BA%CE%B5%CF%85%CE%AE.1162/
    Most Internet users will search in Greek for "Citroen 2cv ανακατασκευή". Which method should i use in order for Google better accessing my data?

    My English dont help a lot I hope you understand what my problem is. Does the wrong romanization effect the best possible google indexing? What is better to use? Romanize on or off?
     
  6. Mike

    Mike XenForo Developer Staff Member

    For the "υ" character, the romanization seems to be listed as y, u, or i rather than "v" that you have mentioned. It appears the last character is skipped because of the diacritic. I did have a look and I don't think that can be explicitly changed right now as there is a very large number of possible combinations.

    In terms of the URL encoded value, that's expected as that's what the actual URL is and how it must be. The browser handles decoding to display it "properly". You'll see this exact thing with links in Wikipedia (http://el.wikipedia.org/wiki/%CE%9D%CE%AD%CE%B1_%CE%A5%CF%8C%CF%81%CE%BA%CE%B7).

    You can learn more about route filters here: https://xenforo.com/help/route-filters/

    Romanization is not perfect. It's designed mostly to be an alternative to long URLs like that, but because there are 100s of thousands of possible characters and differing rules per language (or even debatable rules within a language), it can't cover every case. The options are really to allow the full characters in the URLs (no romanization), romanize, or remove the text from the URLs entirely. It's really your choice what you want to use. While URLs may count, it's the content on the page. Searching for "Citroen 2cv ανακατασκευή" gives your forum as the second result.
     
  7. Pierre Boulanger

    Pierre Boulanger Active Member

    Thank you for the time you spent explaining and trying to help me. You should consider implementing the custom URL option thought. It would help a lot of people
     

Share This Page