1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed Rich Text Editor not rendered in Responsive Mode

Discussion in 'Resource Manager Resolved Bugs' started by Freelancer, May 9, 2016.

  1. Freelancer

    Freelancer Well-Known Member

    OSX Safari browsers (Mobile and Desktop)
    XF 1.5.7
    XFRM 1.2.3

    It seems that the rich text editor is not appearing for the text input form fields for other text editor fields except the first editor field present when creating or editing resources – in responsive mode and Safari browsers.

    I narrowed it down. It happens with secondary form fields (custom fields with Rich Text Editor Input). When I discovered it, I was on an iPad. I then tested it on the computer – on the desktop it was just as it should be (with editor displayed).

    Next I tested it on the computer again, but with responsive layout testing enabled and bingo, the editor is gone again. And not only in my custom style but clearly in Default Style too. I was able to reproduce it every time. Please test it in responsive mode or on a pad or phone.

    Summarized: "Editor" disappears for secondary "Richt Text Custom Form Fields" in CREATE & EDIT Resource Item
    • Only in Responsive mode
    • Also in Default Style
    • The HTML is not even rendered
    I could guess that it maybe originates from having a second instance of the rich text editor on the same page in combination of Safari "sensitivity"...?

    Please advise.

    Desktop Mode
    desktop_mode.jpg richttexteditor.jpg

    Responsive Mode
    repsonsive_mode.jpg textarea_only.jpg
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    This is intentional and is due to restrictions with the way that some mobile devices handle rendering multiple editors in the same page.
     
    Freelancer likes this.
  3. Freelancer

    Freelancer Well-Known Member

    Oh bummer... I hoped it wasn't the case. Most members I have use mobile devices. That leaves them unable to make nice formatted descriptions for extra fields. :oops:
     

Share This Page