1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Responsive Message Controls Menu 1.1.2

Save space in responsive views :)

  1. Steve F

    Steve F Well-Known Member

    Steve F submitted a new resource:

    Message Controls Menu - Save space in responsive views :)

    Read more about this resource...
     
    DRE, iTuN3r, Chris D and 1 other person like this.
  2. Chris D

    Chris D XenForo Developer Staff Member

    Great work, Steve. Love this.

    Might give this a try when I'm less busy!
     
    Steve F likes this.
  3. DEZero

    DEZero Well-Known Member

    Will definitely use on my gaming site :) great work Steve (y)
     
    Steve F likes this.
  4. Steve F

    Steve F Well-Known Member

    I hope the silence is a good thing ;)

    Being out of town and having to browse my own forum with my phone has been quite nice. Easier to tap the links I want to tap. :)
     
  5. iTuN3r

    iTuN3r Well-Known Member

    Just what i needed Steve !! Going to give this a try later this morning.
     
  6. Steve F

    Steve F Well-Known Member

  7. Steve F

    Steve F Well-Known Member

  8. Chris D

    Chris D XenForo Developer Staff Member

    Hi Steve,

    Just installed the latest version and checked on the default style and I see this:

    upload_2014-9-8_8-56-23.png

    So it's the standard Menu rather than the XF menu Icon.

    This is at https://xenresources.com if you want to take a look.

    Chris
     
  9. Steve F

    Steve F Well-Known Member

    Did it create the template 'message_control_menu.css' ?
     
  10. Chris D

    Chris D XenForo Developer Staff Member

    Nope, that template doesn't appear in the XML file.

    Just downloaded again, that template appears to be missing.
     
  11. Steve F

    Steve F Well-Known Member

    Chris D likes this.
  12. Chris D

    Chris D XenForo Developer Staff Member

    Works great now :)
     
    Steve F likes this.
  13. Steve F

    Steve F Well-Known Member

  14. rainmotorsports

    rainmotorsports Well-Known Member

    Thanks Steve this is perfect. The overflow might not seem like much harm on the stock theme. But on the vBulletin like control styling we run it's essential:
    upload_2014-9-14_6-39-52.png
     
    Steve F likes this.
  15. Stuart Wright

    Stuart Wright Well-Known Member

    Got some problems with this in our style, most probably because we display the post information (poster, timestamp) above the post and the menu appears correctly below the post but also incorrectly above it, which is not what I want to happen. I've highlighted the errors in the screen capture below.
    I'm guessing this is an issue with the template search+replace?
    What should I do?

    wrong.jpg
     
    Last edited: Sep 21, 2014
    Steve F likes this.
  16. Steve F

    Steve F Well-Known Member

    I think this will work for you.

    Add this to EXTRA.css (or whatever template you add your customizations to)

    Code:
    .message .visibleResponsiveMedium .InlineModCheck,
    .message .visibleResponsiveMedium .authorEnd,
    .message .visibleResponsiveMedium .datePermalink
    {
        display: none;
    }
    

    Edit: I just noticed it was also apply to the upper. I'll register and see if there is something else I can do.
     
    Last edited: Sep 21, 2014
  17. Steve F

    Steve F Well-Known Member

    This should do

    Code:
    .messageMeta .visibleResponsiveMedium .InlineModCheck,
    .messageMeta .visibleResponsiveMedium .authorEnd,
    .messageMeta .visibleResponsiveMedium .datePermalink
    {
        display: none;
    }
    
    .messageMeta2 .visibleResponsiveMedium .InlineModCheck,
    .messageMeta2 .visibleResponsiveMedium .authorEnd,
    .messageMeta2 .visibleResponsiveMedium .datePermalink
    {
        display: block;
    }
     
  18. Stuart Wright

    Stuart Wright Well-Known Member

    Thanks but the new control menu is still appearing above the post.
     
    Last edited: Sep 22, 2014
  19. Steve F

    Steve F Well-Known Member

    Can you grab another screenshot of what you see? Or try the below and see if it works? Without seeing everything I can't really debug it.

    Code:
    .messageMeta2 .Popup.privateControlsPopup.item
    {
    display: none;
    }
    .messageMeta .visibleResponsiveMedium .InlineModCheck,
    .messageMeta .visibleResponsiveMedium .authorEnd,
    .messageMeta .visibleResponsiveMedium .datePermalink
    {
    display: none;
    }
    
    .messageMeta2 .visibleResponsiveMedium .InlineModCheck,
    .messageMeta2 .visibleResponsiveMedium .authorEnd,
    .messageMeta2 .visibleResponsiveMedium .datePermalink
    {
    display: block;
    }
     
  20. Stuart Wright

    Stuart Wright Well-Known Member

    Thanks, I did a bit of tidying up and put this in in the end, which works:
    Code:
    .messageMeta .InlineModCheck,
    .messageMeta .authorEnd,
    .messageMeta2 .authorEnd,
    .messageMeta .datePermalink,
    .messageMeta2 .Popup.privateControlsPopup.item
    {
      display: none;
    }
    
    .messageMeta2 .InlineModCheck,
    .messageMeta2 .datePermalink
    {
      display: block;
    }
    
    Still working on optimising it.
     
    Last edited: Sep 22, 2014

Share This Page