1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Requested Page Not Found on All Posts

Discussion in 'Troubleshooting and Problems' started by VintageDon, Mar 16, 2016.

  1. VintageDon

    VintageDon New Member

    Hello:

    So I have a new installation of Xenforo, and I'm getting 404 errors on all of the actual forum threads; doesn't matter what forum it's in. The forum link itself works, and I can drill down and see the post itself, but when I try to access it, I get the requested page not found.

    There are no errors in the ACP, but I can clearly see a 404 error in the Apache error log for the site. Of course, the first thing you think of is mod_rewrite, but it's properly configured and working for all other sites on the server. I've tried it with the htaccess, without the htaccess, trying it with and without the friendly URLs (it still happens without the friendly URLs, which to me points to a non-rewrite issue), and it still doesn't work.

    Note that this is a new forum install, and I didn't discover this until well after I'd installed the theme, some addons, and so forth. So I'm not sure if it was ever working. This also seems to be the only thing not working, although it's obviously a big one. Am running it behind CloudFlare, but putting it in development mode to disable caching and clearing my own cache doesn't help.

    Some specifics:
    Xenforo Version: 1.5.x
    Addons: Really too many to list, but nothing affecting forum threads.
    Example Forum URL: http://minestyria.com/forums/announcements/
    Example Thread 404: http://minestyria.com/threads/forum-rules.1/

    Am a Linux administrator, so no need to dumb anything down for me. I really do believe it's rooted in my settings somewhere, rather than the actual OS or Apache, since everything else on the server is running fine, and I make liberal use of mod_rewrite throughout (I *am* using the default htaccess for Xenforo).

    As Always,
    Don
     
  2. Mike

    Mike XenForo Developer Staff Member

    Are you using an route filters? If so, try disabling them.

    Try going to <url>/install/ and rebuilding the master data. Did that help?

    If that doesn't help, try enabling debug mode. What is the not found error showing now?
     
    VintageDon likes this.
  3. VintageDon

    VintageDon New Member

    Hello:

    There was a single route filter for xengallery. Disabling it did no good.

    However, trying to rebuild the master data threw this error:

    =====
    An exception occurred: Callback XenForo_CronEntry_Warnings::expireWarnings is invalid (Invalid Class). in /home/mcstyria/public_html/library/XenForo/DataWriter.php on line 1359
    =====

    This led me to a file health check and what appeared to be some corrupted files. Trying to rebuild the caches threw the same issue.

    Grabbing the full download, I re-uploaded those and then rebuilt the cache, and it appears everything is working

    Thanks for giving me that push in the right direction.

    As Always,
    Vint
     
    Mike likes this.

Share This Page