1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Registered users can do nothing

Discussion in 'Troubleshooting and Problems' started by Sunka, Feb 6, 2015.

  1. Sunka

    Sunka Well-Known Member

    Suddenly all users whos registered and only those users which are new (registered in few past days) on my site can do nothing, even to see site. All permissions are set OK, but analyze permissions tool give results NO.

    Below are pictures showing registered usergroup permissions, and Analyze permission for one user who is only in registered group.

    It is seems to me that for some reason, every user who register have every permission set to NO, even usergroup permissions are set to allow.

    I have tried with all add ons disabled, but result is same. Every new registered user have all permissions set to NO no matter what I set in Admin control panel

    [​IMG]

    [​IMG]
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Click on the Details link for Search and screenshot it.
     
  3. Sunka

    Sunka Well-Known Member

    Same as above.

    I found something.
    User can register, but all permissions are set suddenly to NO when user activate account (e-mail link). Then only if I mannualy rebuild user caches, permissions to that users revert to normal. After rebuild cache every new user have same problem until I rebuild user caches again
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    That sounds like an add-on may be related.

    Disable all add-ons and do some testing to check which one it is.

    Presumably the members are registering directly and not via Tapatalk or aMember or any other third party application?
     
  5. Sunka

    Sunka Well-Known Member

    I have tried with all add on disabled (via config.php), and results are same. Tapatalk is not installed on my site, user can only register directly, default xenforo system.

    So, every new user after activate account via e-mail link is prohibited to do anything untill I manually rebuild user cache in ACP.

    Please help
     
  6. Sunka

    Sunka Well-Known Member

    Update.

    Even if I disabled e-mail confirmation, user are prohibited to do anything untill I rebuild manually users cache in ACP
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    If it's the forum linked in your signature, I see a lot of add-ons installed and active.

    You will need to disable all add-ons and revert to a default style and do some testing/troubleshooting.
     
  8. Sunka

    Sunka Well-Known Member

    I have allready tried with all addons disabled - $config['enableListeners'] = false;
    Style is default xenforo style
     
  9. Mike

    Mike XenForo Developer Staff Member

    Disabling listeners is not entirely the same as disabling add-ons. Regardless, please reimport the master data via the install/ URL. Does that change the permission analysis results?
     
  10. Sunka

    Sunka Well-Known Member

    No, result is same.
    I will try disable all addons manually in ACP to see is this will correct something
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Something must have changed.

    Your opening post states "suddenly".
    Problems of this nature don't occur spontaneously.
     
  12. Sunka

    Sunka Well-Known Member

    Strange.
    I have manually disabled all addons in ACP, and then enabled five by five and tried new user registration to see if permission will be OK.

    Final result was that after enabled all addons, everything is OK with new user permission.

    @Mike, @Brogan - when addon is disabled and then enabled, some cache rebuilded or something like that happened, so could that been reason for all is working OK now?
    Any hint to know where exactly is problem?
     
  13. Sunka

    Sunka Well-Known Member

  14. Daniel Hood

    Daniel Hood Well-Known Member

    I'm not entirely convinced this was the same issue. The problem with modeat or essentials was fixed by rebuilding user cache and should have also been fixed by rebuilding master data. Might want to make sure you don't have another problem going on.
     
    Sunka likes this.

Share This Page