• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Redis Flood Check 2.0.1

No permission to download

Xon

Well-known member
#1
Xon submitted a new resource:

Redis Flood Check - Use redis for flood checking rather than MySQL

Moves flood checking use Redis-based atomic keys rather than scratch tables in MySQL


Contributing features or bug fixes
Please create a GitHub Pull request via the "Find more info at github.com..." link.

Contributions

If you appreciate this add-on, please consider a contribution via PayPal. Details will be provide via private conversation.

Please contact me if you wish for different licencing arrangements.
Read more about this resource...
 

Mike Edge

Well-known member
#5
Hi @Xon trying to install this I receive the error

The following errors must be resolved before continuing:
  • This add-on requires Redis Cache to be installed and configured


Code:
$config['cache']['enabled'] = true;
$config['cache']['frontend'] = 'Core';
$config['cache']['frontendOptions']['cache_id_prefix'] = 'hockey_';

$config['cache']['backend'] = 'Redis';
$config['cache']['backendOptions'] = array(
'server' => '10.99.0.10',
'port' => 6379,
'connect_retries' => 2,
'use_lua' => true
);
Redis is running
Code:
# service redis status
Redirecting to /bin/systemctl status redis.service
● redis.service - Redis persistent key-value database
   Loaded: loaded (/usr/lib/systemd/system/redis.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/redis.service.d
           └─limit.conf
   Active: active (running) since Mon 2017-11-27 09:19:10 UTC; 11s ago
  Process: 12455 ExecStop=/usr/libexec/redis-shutdown (code=exited, status=0/SUCCESS)
 Main PID: 12470 (redis-server)
   CGroup: /system.slice/redis.service
           └─12470 /usr/bin/redis-server 10.99.0.10:6379

Nov 27 09:19:10 db-es systemd[1]: Starting Redis persistent key-value database...
Nov 27 09:19:10 db-es systemd[1]: Started Redis persistent key-value database.
and I can telnet to 10.99.0.10 6379 from 10.99.0.14 which is where XenForo is installed, so not a connection permission issue.

Also /admin.php?options/groups/RedisCacheOptions/ is a blank page other then the header.
 

Xon

Well-known member
#6
@Mike Edge that is the XF1 cache config.

XF2 cache config should look like:
Code:
$config['cache']['enabled'] = true;
$config['cache']['namespace'] = 'hockey_';
$config['cache']['provider'] = 'SV\RedisCache\Redis';
$config['cache']['config'] = array(
    'server' => '10.99.0.10',
   'port' => 6379,
   'connect_retries' => 2,
   'use_lua' => true
    );
(Provider need to be SV\RedisCache\Redis not Redis)