1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Bypass Flood Check Not Working

Discussion in 'XenForo Questions and Support' started by Brian Woody, Jun 22, 2016.

  1. Brian Woody

    Brian Woody Member

    I have my admin account set to Allow for Bypass Flood Check and Bypass Spam Check, but it's still applying those rules to me. Any advice on how to fix this? I haven't changed any settings that would affect it, except for possibly installing the UI.X theme.

    Instead of making a new thread, might as well post this here before anyone responds:

    I'm also having an issue with # links not working. I thought it was just a problem with my Page html content, but it's also happening with Threads when I try to link to specific post numbers. The link will be inserted correctly, which when clicked, the screen will just kind of jerk and then return to the same position.

    [Edit] Yup, seems to be an issue with my UI.X. I just got this warning:

    "Uh Oh! It looks like there's an error in your page's javascript. There will likely be significant issues with the use of the forum until this is corrected. If you are unable to resolve this and believe it is due to a bug in your Audentio Design theme, contact Audentio support and include a copy of the text between the designated areas from your javascript console. This is the error:

    SyntaxError: Unexpected end of JSON input"
    Last edited: Jun 22, 2016
  2. Brian Woody

    Brian Woody Member

  3. Mike

    Mike XenForo Developer Staff Member

    Your UI.X issues are almost certainly unrelated and would probably be best directed at the author.

    Use the permission analyzer to confirm the flood check permission final value.
  4. Brian Woody

    Brian Woody Member

    Got it fixed, thanks! Still not sure what to do about the merging issue, though.
  5. Tracy Perry

    Tracy Perry Well-Known Member

    If you haven't made any modifications to it - and if you have set up UI.X correctly - you should just be able to do a revert.
  6. Brian Woody

    Brian Woody Member

    A revert? As in, just uninstall UI.X? I did try that, and it did work, though the actual UI.X theme remained in effect (which did, essentially, completely fix the problem, though I lost all of the UI.X functionality). However, when I tried to reinstall it, it had the same merge issues and broke my JS.
  7. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    A revert is reverting outdated templates. From the main page in the AdminCP it should show you a banner at the top that says Some templates may be outdated or something along those lines. From there you can click a link to merge templates. Also wouldn't hurt to make sure you are using the newest version of your theme.
  8. Brian Woody

    Brian Woody Member

    Oh, yes, I have tried that. I get this error: "The custom template is out of date but has been edited more recently than the parent. Merging can only be done by hand."
  9. Tracy Perry

    Tracy Perry Well-Known Member

    No, you are trying to MERGE the template.. not revert it.

    When opening the template with the issue, you should see this at the bottom of it.

    Screen Shot 2016-06-23 at 4.41.53 PM.png

    Notice the Revert Template Button... that's what you need to select. But before you do, write down the template name and then copy the existing data into the clipboard and into an editor in case it doesn't revert the correct data (never had this happen, but I believe in the Boy Scout motto).
  10. Brian Woody

    Brian Woody Member

    Ah, ok, thanks for the info! I've managed to revert the template, and that did get the error message to go away, but the site's javascript is still not working correctly while UI.X is installed. I have a support ticket with them, though, so hopefully they can help me get it figured out.

Share This Page