Redis Flood Check

Redis Flood Check 2.0.4

No permission to download
  • Increase minimum supported php version to v7.0.0+
  • Fix add-on description
  • Like
Reactions: Sunka and Masetrix
  • Minor code clean
  • In non-lua mode, fix a potential race condition between failing to create the flood key and checking the TTL on that key which could result in incorrectly handling if the user should be blocked by the flood check
  • Like
Reactions: Sunka
  • Only warn if Redis Cache isn't configured, do not block installing/upgrading
  • Like
Reactions: Sunka
  • Block installing if Redis Cache add-on is not installed & configured.
  • Like
Reactions: eva2000
  • v1.x.y is XF1, so bump to v2.x.y
  • phpdocs + cleanup
  • Fix flood-check with lua disabled
Top