Redirection on inline moderation


Well-known member
I upgraded to a new instance on Linode from Ubuntu 20.04 to 22.04, and ever since I've been getting redirected to home page after inline moderation. Can someone shed a light as I can't figure it out what exactly has changed. I suspect it's something within nginx config..

My server blocks:​

server {
    listen 80;
    listen [::]:80;
    return 301 https://$host$request_uri;

    # Logs
    access_log /var/log/nginx/;
    error_log /var/log/nginx/;

server {

    # SSL configuration
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    include snippets/;
    include snippets/ssl-params.conf;

    # Root dir
    root           /var/www/;
    index index.php index.html index.htm;


    location / { try_files $uri $uri/ /index.php?$uri&$args;  }

    # xenforo internal use
    location /(internal_data|install_data|library|src) { internal; }

    location ~ \.php$ {
        # With php-fpm sock:
        fastcgi_pass unix:/var/run/php/php8.1-fpm.sock;
        include snippets/fastcgi-php.conf;
        fastcgi_read_timeout 3600;

    # Cache-Control headers
    expires $expires;

    # deny access to .htaccess files
    location ~ /\.ht {
            deny all;

    location ~ /.well-known {
        allow all;



# regex to split $uri to $fastcgi_script_name and $fastcgi_path
fastcgi_split_path_info ^(.+?\.php)(/.*)$;

# Check that the PHP script exists before passing it
try_files $fastcgi_script_name =404;

# Bypass the fact that try_files resets $fastcgi_path_info
# see:
set $path_info $fastcgi_path_info;
fastcgi_param PATH_INFO $path_info;

fastcgi_index index.php;
include fastcgi.conf;

Also, should I add this to fastcgi-php.conf?
fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;

Let me know if I need to check into other config files. Thanks!
Last edited:
I'm wondering if has any relation to this I just reported:
One more config to help debug:


fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;
fastcgi_param  QUERY_STRING       $query_string;
fastcgi_param  REQUEST_METHOD     $request_method;
fastcgi_param  CONTENT_TYPE       $content_type;
fastcgi_param  CONTENT_LENGTH     $content_length;

fastcgi_param  SCRIPT_NAME        $fastcgi_script_name;
fastcgi_param  REQUEST_URI        $request_uri;
fastcgi_param  DOCUMENT_URI       $document_uri;
fastcgi_param  DOCUMENT_ROOT      $document_root;
fastcgi_param  SERVER_PROTOCOL    $server_protocol;
fastcgi_param  REQUEST_SCHEME     $scheme;
fastcgi_param  HTTPS              $https if_not_empty;

fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;
fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;

fastcgi_param  REMOTE_ADDR        $remote_addr;
fastcgi_param  REMOTE_PORT        $remote_port;
fastcgi_param  REMOTE_USER        $remote_user;
fastcgi_param  SERVER_ADDR        $server_addr;
fastcgi_param  SERVER_PORT        $server_port;
fastcgi_param  SERVER_NAME        $server_name;

# PHP only, required if PHP was built with --enable-force-cgi-redirect
fastcgi_param  REDIRECT_STATUS    200;
I did notice, that both when trying to change my forum style or using inline-mod I get a:

303 error

Top Bottom