1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Redirect non-www to www & force SSL

Discussion in 'XenForo Questions and Support' started by ungovernable, Feb 9, 2016.

  1. ungovernable

    ungovernable Member

    Title says it all.

    Tried doing it through htaccess but it's not working. Yes mod_rewrite is enabled


    Code:
    #   Mod_security can interfere with uploading of content such as attachments. If you
    #   cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #   SecFilterEngine Off
    #   SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 405 default
    ErrorDocument 406 default
    ErrorDocument 500 default
    ErrorDocument 501 default
    ErrorDocument 503 default
    
    <IfModule mod_rewrite.c>
       RewriteEngine On
    
       #   If you are having problems with the rewrite rules, remove the "#" from the
       #   line that begins "RewriteBase" below. You will also have to change the path
       #   of the rewrite to reflect the path to your XenForo installation.
       #RewriteBase /xenforo
    
       #   This line may be needed to enable WebDAV editing with PHP as a CGI.
       #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
       RewriteCond %{REQUEST_FILENAME} -f [OR]
       RewriteCond %{REQUEST_FILENAME} -l [OR]
       RewriteCond %{REQUEST_FILENAME} -d
       RewriteRule ^.*$ - [NC,L]
       RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
       RewriteRule ^.*$ index.php [NC,L]
    
       RewriteCond %{HTTP_HOST} !^www\.
       RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
    
       RewriteCond %{SERVER_PORT} 80
       RewriteRule ^(.*)$ https://www.libertaire.net/$1 [R,L]
    </IfModule>
    
    
     
  2. Mike

    Mike XenForo Developer Staff Member

    You need to move the rewrite rules you added to directly after this line:
    Code:
    RewriteEngine On
     
    ungovernable likes this.
  3. ungovernable

    ungovernable Member

  4. Optic

    Optic Well-Known Member

    Make sure you also update your Board URL to HTTPS too in Admin CP > Home > Options > Basic Board Information.
     
  5. Mike

    Mike XenForo Developer Staff Member

    The URL is detected based on the parameters provided from the server. How have you setup HTTPS? Are you using CloudFlare's flexible SSL?
     
  6. ungovernable

    ungovernable Member

    Everything seems fixed after i set "https" in the Board URL settings. I'm not using CloudFlare, i'm using my own SSL certificate bought from PositiveSSL
     
    Gossipy and StarArmy like this.

Share This Page