XF 2.2 Redirects while moving from community to root

Renegade

Well-known member
So I am moving my forum from 'community' folder to root. I have everything setup and working except redirects from old URL to the new.

I have entered this in the htaccess file in the root folder as mentioned by Brogan here - > https://xenforo.com/community/threads/frequently-asked-questions.5183/#post-180455
RewriteRule ^community/(.*)?$ /$1 [R=301,L]

This is how the htaccess file looks like in the root directory
# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

RewriteEngine On
Options +FollowSymlinks

#RewriteEngine On
#RewriteCond %{HTTPS} !on
#RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

#RewriteEngine On
#RewriteCond %{HTTP_HOST} ^www\.techenclave\.com$
#RewriteRule ^/?$ "http\:\/\/techenclave\.com\/" [R=301,L]

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
RewriteRule ^community/(.*)?$ /$1 [R=301,L]

If I enter the old URL in the browser, I get this error message on the forum

Oops! We ran into some problems.​


The requested page could not be found.

What am I doing wrong.
 
Top