• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Redactor issues...

Kainzo

Active member
#1
So in the previous builds of XF 1.1 and beyond, I could copy and paste posts into the old editor and it would keep the color, etc on the XF post.

Now, for whatever reason, I can copy and paste it in from a XF post and it doesnt keep colorization.

Is there a way to go back to the old editor or at the very least fix these types of issues?
 

Chris D

XenForo developer
Staff member
#2
It's not a bug, and in fact the behavior you're describing as desired was in fact more often than not reported as a bug itself in the old editor.

The new editor deliberately strips out various bits of formatting so it is behaving as expected.
 

Mike

XenForo developer
Staff member
#3
As noted, the previous behavior had a lot of other problems. Colors are maintained if you copy from within the editor though.
 

Kainzo

Active member
#4
It's not a bug, and in fact the behavior you're describing as desired was in fact more often than not reported as a bug itself in the old editor.

The new editor deliberately strips out various bits of formatting so it is behaving as expected.
That's a loss of functionality, it's a lot easier to remove formatting than to re-add it. Not to mention the new editor doesn't allow for quick-colorization when using the color tool.
 

Martok

Well-known member
#5
That's a loss of functionality, it's a lot easier to remove formatting than to re-add it. Not to mention the new editor doesn't allow for quick-colorization when using the color tool.
I disagree, it's not that easy to remove formatting. On my forum we often quote from other sites and it was a real nightmare with the various font sizes, font types and colours used (which included web link colourings that didn't match our own). It took a lot of effort to remove the formatting. Yes, now redactor does strip the colouring but it's a small price to pay to add it back in compared to the nightmare we had previously.
 

Chris D

XenForo developer
Staff member
#6
This is a perfect example of how changes will never make everyone truly happy. What is a loss of functionality for some is considered to be a resolved bug for many.

As such, there really is no solution.

You could try looking at the TinyMCE Quattro add-on (http://xenforo.com/community/resources/tinymce-quattro-and-its-wysiwyg-bbcodes.1881/) By @cclaerhout

This turns the XF editor into TinyMCE 4.x which is the version after the version that was in XF 1.1.

It may restore that behavior you're more familiar with.
 

Kainzo

Active member
#7
This is a perfect example of how changes will never make everyone truly happy. What is a loss of functionality for some is considered to be a resolved bug for many.

As such, there really is no solution.

You could try looking at the TinyMCE Quattro add-on (http://xenforo.com/community/resources/tinymce-quattro-and-its-wysiwyg-bbcodes.1881/) By @cclaerhout

This turns the XF editor into TinyMCE 4.x which is the version after the version that was in XF 1.1.

It may restore that behavior you're more familiar with.
I understand that not all updates make user's happy, but this was a drastic change, I chose XenForo because of the easy to use editor now it's become a daily chore and a hassle for me to use.

If I want to use the same color over and over again, I have to re-select it. Do you know of any addon that changes it so it keeps the same color after selecting one or maybe this is something we can bug Redactor about fixing. I'm not sure if it's implementation or design.
 

cclaerhout

Well-known member
#8
I understand that not all updates make user's happy, but this was a drastic change, I chose XenForo because of the easy to use editor now it's become a daily chore and a hassle for me to use.

If I want to use the same color over and over again, I have to re-select it. Do you know of any addon that changes it so it keeps the same color after selecting one or maybe this is something we can bug Redactor about fixing. I'm not sure if it's implementation or design.
Chris already told you, the last version of MCE4 has this feature and the color in memory is displayed. Now to be fair, the full color pickup is no more available in the official MCE4 (yet ?). But you will have in the quote addon thanks to the XenForo template system. This code is a conversation of previous MCE3 code.