XF 1.5 Read failed - connection closed?

Nirjonadda

Well-known member
Bounced email handling issue, I am getting lot of Server Error Logs. Please let me know the fix.

Email Options Setting:

ScreenShot00269.png

Code:
Error Info
Zend_Mail_Protocol_Exception: read failed - connection closed? - library/Zend/Mail/Protocol/Pop3.php:174
Generated By: Unknown Account, 33 minutes ago
Stack Trace

#0 /home/nadda/public_html/library/Zend/Mail/Protocol/Pop3.php(113): Zend_Mail_Protocol_Pop3->readResponse()
#1 /home/nadda/public_html/library/Zend/Mail/Storage/Pop3.php(190): Zend_Mail_Protocol_Pop3->connect('mail.nirmoladda...', 995, 'TLS')
#2 /home/nadda/public_html/library/XenForo/Model/EmailBounce.php(288): Zend_Mail_Storage_Pop3->__construct(Object(stdClass))
#3 /home/nadda/public_html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
#4 /home/nadda/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999990463257, '')
#5 /home/nadda/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999990463257, '', false)
#6 /home/nadda/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#7 /home/nadda/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#8 {main}

Request State

array(3) {
  ["url"] => string(39) "https://..../deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(80) "/threads/ayumi-hamasaki-arena-tour-2016-bluray-ipad-720p-aac-x264-hdspad.143019/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Nirjonadda

Well-known member
One more error log.

Code:
Error Info
Zend_Exception: Not a valid Mime Message: End Missing - library/Zend/Mime/Decode.php:72
Generated By: Unknown Account, 4 minutes ago
Stack Trace

#0 /home/nadda/public_html/library/Zend/Mime/Decode.php(92): Zend_Mime_Decode::splitMime('--mixed-Cpanel:...', 'mixed-Cpanel::E...')
#1 /home/nadda/public_html/library/Zend/Mail/Part.php(222): Zend_Mime_Decode::splitMessageStruct('--mixed-Cpanel:...', 'mixed-Cpanel::E...')
#2 /home/nadda/public_html/library/Zend/Mail/Part.php(292): Zend_Mail_Part->_cacheContent()
#3 /home/nadda/public_html/library/Zend/Mail/Part.php(517): Zend_Mail_Part->countParts()
#4 /home/nadda/public_html/library/XenForo/BounceParser.php(182): Zend_Mail_Part->rewind()
#5 /home/nadda/public_html/library/XenForo/BounceParser.php(170): XenForo_BounceParser->_process()
#6 /home/nadda/public_html/library/XenForo/Model/EmailBounce.php(12): XenForo_BounceParser->__construct(Object(Zend_Mail_Message), 'bounce@nirmolad...', 'b94e0396b0f0ac8...')
#7 /home/nadda/public_html/library/XenForo/Deferred/EmailBounce.php(52): XenForo_Model_EmailBounce->processBounceEmail('Return-Path: <r...')
#8 /home/nadda/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999980926514, '')
#9 /home/nadda/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999980926514, '', false)
#10 /home/nadda/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#11 /home/nadda/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#12 {main}

Request State

array(3) {
  ["url"] => string(39) "https://.../deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(1) "/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Mike

XenForo developer
Staff member
If these are sporadic issues, they would mostly seem to indicate networking/connectivity type errors.

If the latter error happens frequently, we may need to consider further steps. (There's an open bug report with a similar error.)
 

Nirjonadda

Well-known member
If these are sporadic issues, they would mostly seem to indicate networking/connectivity type errors.

If the latter error happens frequently, we may need to consider further steps. (There's an open bug report with a similar error.)
This error happening all time.

Code:
Error Info
Zend_Mail_Protocol_Exception: cannot connect to host; error = (errno = 0 ) - library/Zend/Mail/Protocol/Pop3.php:109
Generated By: Unknown Account, 31 minutes ago
Stack Trace

#0 /home/nadda/public_html/library/Zend/Mail/Storage/Pop3.php(190): Zend_Mail_Protocol_Pop3->connect('ssl://mail.nirm...', 995, 'SSL')
#1 /home/nadda/public_html/library/XenForo/Model/EmailBounce.php(288): Zend_Mail_Storage_Pop3->__construct(Object(stdClass))
#2 /home/nadda/public_html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
#3 /home/nadda/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999990463257, '')
#4 /home/nadda/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999990463257, '', false)
#5 /home/nadda/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#6 /home/nadda/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#7 {main}

Request State

array(3) {
  ["url"] => string(39) "https://www.nirmoladda.com/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(45) "/threads/video.138966/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Mike

XenForo developer
Staff member
That indicates you're having problems connecting to your POP3 server. You should check that your POP3 connection details are correct. If they are, you need to confirm that your POP3 server is running. If it is, then you'll need to look into why you can't connect to it. Your sysadmin would be best positioned to do this.
 
Top