XF 2.1 Email to **** failed: Connection could not be established with

Explanation of the error: A user tried desperately to reset his password. However, he never received an email and has now registered again.

I have had the problem before and honestly I keep getting such e-mail error messages that I have often ignored because I simply did not know what was going on or no user had previously complained about problems.

Can someone help me how to fix this? :(



Xenforo Version: XF 2.1.6

Code:
Fehlermeldung des Servers
[LIST]
[*]Swift_TransportException: Email to******* @gmx.de failed: Connection could not be established with host [php_network_getaddresses: getaddrinfo failed: Name or service not known #0]
[*]src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php:277
[/LIST]
[LIST]
[*]Generiert durch: Unbekanntes Benutzerkonto
[*]2. Februar 2020 um 15:00 Uhr
[/LIST]
Stapelverfolgung
#0 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php(62): Swift_Transport_StreamBuffer->_establishSocketConnection()
#1 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php(113): Swift_Transport_StreamBuffer->initialize(Array)
#2 src/XF/Mail/Mailer.php(274): Swift_Transport_AbstractSmtpTransport->start()
#3 src/XF/Mail/Queue.php(138): XF\Mail\Mailer->send(Object(Swift_Message), Object(Swift_SmtpTransport), Array)
#4 src/XF/Job/MailQueue.php(12): XF\Mail\Queue->run(G)
#5 src/XF/Job/Manager.php(253): XF\Job\MailQueue->run(G)
#6 src/XF/Job/Manager.php(195): XF\Job\Manager->runJobInternal(Array, G)
#7 src/XF/Job/Manager.php(79): XF\Job\Manager->runJobEntry(Array, G)
#8 job.php(42): XF\Job\Manager->runQueue(false, 8)
#9 {main}
Benötigter Status
array(4) {
  ["url"] => string(8) "/job.php"
  ["referrer"] => string(99) "https://www.**********.berlin/index.php?threads/upside-berlin-max-und-moritz.182/page-9"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Deathstarr

Well-known member
It appears that you have the setting for your email server incorrect.

Check them here
ACP>>Setup>>Options>>Email Settings.

If you are using the default PHPemail from your host, then you need to check with your host if they have the port 25 open or if they changed it, I recommend setting up something link mailgun, or similar to send emails.
 
Thank you.

Didnt changed any E-Mail settings, but thats how its looking (sorry, its in german):
Em_mail-settings.png

I use an E-Mail of my host (1&1) at the same time and I just found this information at my hosts homepage:

For security reasons, SMTP port 25 (outgoing) is blocked. If you want to activate the SMTP port, please contact the support.
So I am going to contact them and see if they can fix it. :)
 
Top