Resource icon

pyftsubset Single File Binary 1.0.2

No permission to download

El Porcharo

Well-known member
Well...
I've deleted PyFtSubset files and reinstalled it again, followed all steps again from scratch while saving pyftsubset.sh to another folder and applied permissions, changed the option in FAM accordingly, then tried to install PyFtSubset again and here come the same error once more.
The frustrating thing is that if I put the wrong path to pyftsubset.sh into the FAM option field, I get (of course) errors while trying to save. But then with the correct path the settings are being saved without problems.

Can't properly recall well, but the first time I set the .sh file, I got a popup saying something like "building fonts map" or something like that. So the path is correct.

I've also changed PHP selector to use PHP 8.1 instead of 7.4, but no difference at all....
 

El Porcharo

Well-known member
Ok... I've read tons of search results and instructions, can't get out of this issue anyway.

I've even tried to chmod the pyftsubset file from the Plesk SSH console. Same as before.
At this point I think I'll give up, looks like not all shared hosting can use this workaround... 😞

So @Kirby could you please advise how to clear out the pending state, so I can remove both add-ons safely?
 

Kirby

Well-known member
So @Kirby could you please advise how to clear out the pending state, so I can remove both add-ons safely?
I am sorry, but based on the information you've provided so far I am unable to provide further help :(

Feel free to start a conversation, provide an admin login (at least with permissions to manage Add-ons and Options) and I'll take a look at your setup.
 

Kirby

Well-known member

El Porcharo

Well-known member
Not really, he had not looked into it yet, at time of release.
But anyway Kirby's been so kind and patient to help me out, the other day, so he made it work!

Aside from thanking him infinitely, I can say that these add-ons are amazing!
My board's Performance score on Google Page Speed jumped from 19 (if I recall well) to 58 , and the TTI dropped from 15,8s to 8,6s!!
 
Last edited:

Abraham54

Well-known member
I have reinstalled Font Awasome

And I used this command for pyftsubset:
/home/xxxxxxxxxxxxx/domains/piepcomp.nl/public_html/src/addons/Kirby/PyFtSubset/bin/pyftsubset.sh

And this gives the folowing error:
Error Output

/home/xxxxxxxxxxxxx/domains/piepcomp.nl/public_html/src/addons/Kirby/PyFtSubset/bin/pyftsubset.sh: line 3: /path/to/pyftsubset/binary:
No such file or directory
 

El Porcharo

Well-known member
make sure to chmod both pyftsubset files, if you look backward in the thread you'll see I had the same issue
 
Top