• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Proxy Images / HTTPS Issues

#1
Hello - it seems that when the image proxy is enabled on my HTTPS site, sites like imgur won't display the image in the post, but do when someone hits 'reply'. This happens if I use either the HTTP or the HTTPS version of the image from imgur.

Examples:
Original Image: https://i.imgur.com/HumdWXB.png



SS1:


SS2:
 
#5
Is this a shared or vps/dedicated? You may check your permission folder or webserver permission.
It's an EC2 instance that I have full administrative control over. Does intenal_data have to be owned by the webserver user, or does the webserver user just have to have read/write/execute rights to that folder? The way it's current set up is 'as-is' from the original install.
 

Sheratan

Well-known member
#6
I would suggest internal_data is owned by webserver user. Don't forget to set it recursive.

You may check the other permission. Running a webserver service under root/sudo is not recommended. That service should be run only by webserver user (like nginx/httpd)
 
#7
The problem isn't happening with all image hosts though, and the strangeness with the image showing when composing a reply, but switching back to 'red x' when posting the reply. It wouldn't seem to me to be a problem with folder permissions.
 

Sheratan

Well-known member
#8
Well, my problem is similiar to you. All image besides proxy images are showing. Image show when edit post, after submit the image are broken :D
 

Mike

XenForo developer
Staff member
#9
When you edit/make a post, the image isn't actually proxied as it stands. Thus that needs to be ignored.

As your example is working here and we proxy images, it's not something inherently related to imgur. This might imply that there's a connectivity issue between your server and theirs -- it's certainly possible that they're actually blocking IPs in the AWS range. Can you try to wget the image from the command line and see what happens?
 
#10
When you edit/make a post, the image isn't actually proxied as it stands. Thus that needs to be ignored.

As your example is working here and we proxy images, it's not something inherently related to imgur. This might imply that there's a connectivity issue between your server and theirs -- it's certainly possible that they're actually blocking IPs in the AWS range. Can you try to wget the image from the command line and see what happens?
If I turn off image proxying, the images show up on the first page refresh. I am also able to successfully wget the image from a cli.
 

Mike

XenForo developer
Staff member
#11
What's your PHP version?

Can you confirm whether it happens with all image hosts (via HTTP and HTTPS)?
 

Solidus

Well-known member
#12
imgur only generates http url's even if you visit the site using https. Manually adding https to imgur url's still work for me though.
 
#13
What's your PHP version?

Can you confirm whether it happens with all image hosts (via HTTP and HTTPS)?
It is happening with imgur http/s and photobucket, I haven't tested others yet, but my users are complaining. I'm running PHP v5.4.37

EDIT: It seems to only be happening for "newly" linked images. My sig on my board is on Photobucket, and that appears properly.
 

Mike

XenForo developer
Staff member
#14
If you submit a ticket with FTP details, I can have a look to see if I can figure out what's going on.
 
#15
I figured out what happened. I had raised the image-size limit, and the server ran out of space!

Once I lowered the proxy size, as well as lowering the lifetime of the proxied images, I regained enough space to operate normally again.
 
#16
If you submit a ticket with FTP details, I can have a look to see if I can figure out what's going on.
I'm having the same issue. No I'm not out of space, I have 2.6TB free. I think it has something to do with using cloudflare and it forcing https? Maybe IMGUR is blocking Cloudflare proxy?






EDIT: turns out, image-proxy text showed it was requesting a GIF that was above the file size limit. Increasing the file size limit for messages fixed it.
 
Last edited: