Profile Completion Steps [Paid] [Deleted]

RobinHood

Well-known member
I'm not sure if this is important or of any use to you but I noticed this my error log from when I was testing yesterday.

Code:
ErrorException: Undefined index: - library/Merc/ProfileCompletion/ViewPublic/Account/AvatarUpload.php:18
Generated By: Unknown Account, Yesterday at 1:04 PM
Stack Trace
#0 /home/site/public_html/library/Merc/ProfileCompletion/ViewPublic/Account/AvatarUpload.php(18): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/ site /...', 18, Array)
#1 /home/ site /public_html/library/XenForo/ViewRenderer/Abstract.php(215): Merc_ProfileCompletion_ViewPublic_Account_AvatarUpload->renderJson()
#2 /home/ site /public_html/library/XenForo/ViewRenderer/Json.php(88): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Json', Array, 'account_avatar_...')
#3 /home/ site /public_html/library/XenForo/FrontController.php(533): XenForo_ViewRenderer_Json->renderView('XenForo_ViewPub...', Array, 'account_avatar_...', NULL)
#4 /home/ site /public_html/library/XenForo/FrontController.php(156): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_JsonText), Array)
#5 /home/ site /public_html/index.php(13): XenForo_FrontController->run()
#6 {main}
Request State
array(3) {
  ["url"] => string(46) "http://www.site.com/account/avatar-upload"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(8) {
    ["use_gravatar"] => string(1) "0"
    ["avatar_date"] => string(1) "0"
    ["avatar_crop_x"] => string(1) "0"
    ["avatar_crop_y"] => string(1) "0"
    ["_xfToken"] => string(54) "39,1344945868,2316993eb15d40b4488531fb5a45b76f1a0f2c7a"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(9) "json-text"
    ["_xfUploader"] => string(1) "1"
  }
}
 

Eagle

Well-known member
I'm not sure if this is important or of any use to you but I noticed this my error log from when I was testing yesterday.

Code:
ErrorException: Undefined index: - library/Merc/ProfileCompletion/ViewPublic/Account/AvatarUpload.php:18
Generated By: Unknown Account, Yesterday at 1:04 PM
Stack Trace
#0 /home/site/public_html/library/Merc/ProfileCompletion/ViewPublic/Account/AvatarUpload.php(18): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/ site /...', 18, Array)
#1 /home/ site /public_html/library/XenForo/ViewRenderer/Abstract.php(215): Merc_ProfileCompletion_ViewPublic_Account_AvatarUpload->renderJson()
#2 /home/ site /public_html/library/XenForo/ViewRenderer/Json.php(88): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Json', Array, 'account_avatar_...')
#3 /home/ site /public_html/library/XenForo/FrontController.php(533): XenForo_ViewRenderer_Json->renderView('XenForo_ViewPub...', Array, 'account_avatar_...', NULL)
#4 /home/ site /public_html/library/XenForo/FrontController.php(156): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_JsonText), Array)
#5 /home/ site /public_html/index.php(13): XenForo_FrontController->run()
#6 {main}
Request State
array(3) {
  ["url"] => string(46) "http://www.site.com/account/avatar-upload"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(8) {
    ["use_gravatar"] => string(1) "0"
    ["avatar_date"] => string(1) "0"
    ["avatar_crop_x"] => string(1) "0"
    ["avatar_crop_y"] => string(1) "0"
    ["_xfToken"] => string(54) "39,1344945868,2316993eb15d40b4488531fb5a45b76f1a0f2c7a"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(9) "json-text"
    ["_xfUploader"] => string(1) "1"
  }
}
Same here. I can't understand why am I getting an avatar error when uploading new avatar. I guess it's a bug or I don't know yet but we'll wait and see provide regular updates.
 

RobinHood

Well-known member
Not sure why, but this seems to have stopped working on for new user registrations. There's no progress notice, progress on the visitor sidebar or on the user profile.

It still appears for existing users who haven't already completed their profile though.
 

Robbo

Well-known member
When you guys give me reports I need to know what tasks you have. They all work differently. As for that error log that is because it does stuff when you upload to show progress without reloading the page. I might have to change things to create page reloads as it keeps causing issues.
 

FredC

Well-known member
I cant seem to get the sidebar widget to appear on the index (forum) or the Profile page. Any ideas?
 

Kimiko

Member
Would it be possible for this add-on to give users virtual currency (with a 3rd party add-on) upon completion of each step?

The way I see it:
1) specify table and field in the general options of this add-on that your currency add-on uses (BD banking for example)
2) specify for each task how much currency is added
3) specify in general options a bonus for 100% completion

If that feature can be tossed in I'd be very interested in this add-on. I'm afraid that just a progress bar isn't going to motivate my users very much and we don't use the trophy system.
 

Robbo

Well-known member
I will have my own add-on released in the future for currency etc which will work for this.

This add-on uses the criteria system. If the add-on you use does too it can work.
 

polle

Active member
When a task is done, you read this:

The task - done

Where can I translate the "- done" ?

Are there any other visible or not visible things I need to translate ?

Also the progress bar is not filling, how to fix that ?

Thanks.
 

Robbo

Well-known member
The phrase is simply "done". Without the - in it.

Are you out of setup mode and also is it only not filling on certain cases? Or is it from things that are done past the next item? Currently it doesn't fill for things after the next task due to a technical limitation which requires a rework of the code that handles it to fix.
 

polle

Active member
The phrase is simply "done". Without the - in it.

Are you out of setup mode and also is it only not filling on certain cases? Or is it from things that are done past the next item? Currently it doesn't fill for things after the next task due to a technical limitation which requires a rework of the code that handles it to fix.
Can you please share the name of the file ? that way I will find it easy instead of searching the whole forum and add ons for "done".

For example I can search for "alert_profile_complete" and translate. Just searching "done" does not show up anything.

Thanks.
 

Robbo

Well-known member
Oh I never added the actual phrase. It is calling it but when XenForo doesn't find a phrase with that name it just uses the name of the phrase. So it is still coming back as "done". So you just have to add your phrase with "done" as the phrase id/name. Next release will have this fixed.
 

polle

Active member
Oh I never added the actual phrase. It is calling it but when XenForo doesn't find a phrase with that name it just uses the name of the phrase. So it is still coming back as "done". So you just have to add your phrase with "done" as the phrase id/name. Next release will have this fixed.
Well, no idea where is getting it from. I will check the main language and try to fix it. Better to be fixed in the next rev, cool.

Thanks.
 

Robbo

Well-known member
It isn't getting it from anywhere. It is calling a phrase called "done" but since the phrase doesn't exist it just outputs "done". For example if the phrase you said above alert_profile_complete didn't exist it would output to the page "alert_profile_complete".
So if you add "done" to you language it will show up translated.
 

fredrikse

Active member
When is this add-on expected to move forward from the beta release? Are there any major bugs not resolved as of today?
 

Robbo

Well-known member
Can I buy it with moneybookers or google checkout ?
I plan to change my website over to money bookers only. Due to limitations of where I am (Australia) I can't use many of the good payment gateways (like google, amazon, *insert any half descent one here*). And due to PayPal basically allowing people to pirate my add-ons for free I will not be using them in the future. Or if I do PayPal payments will have a delay on processing to stop people from scamming me basically.

However, if you can't use PayPal currently you can contact me privately and we can work something else out.

When is this add-on expected to move forward from the beta release? Are there any major bugs not resolved as of today?
There are bugs but they are fairly minor, things like the percent not updating on certain situations. The main reason this was released in beta is because there are features that I am yet to add which I consider part of 1.0. These features are registration steps a user sees after registering, you will be able to select tasks to be on there and it will all be done with Ajax. Basically a streamlined system for a user to initially setup their account.
 
Top