XF 2.1 proc_open() has been disabled & disabled a fundamental core PHP function ini_set

vinnymickey

Active member
I searched and narrowed it down but cannot figure it out totally.

Two issues and not sure if it is related but my host mentioned they tightened security.

First issue: [E_WARNING] proc_open() has been disabled for security reasons I notice new emails are not going out after someone registers.

Second issue: Your server has disabled a fundamental core PHP function ini_set via the disable_functions directive in php.ini.

I changed memory limit on PHP from 128 to 512 but not sure if this will fix the ini_set issue.
 

VersoBit

Active member
I searched and narrowed it down but cannot figure it out totally.

Two issues and not sure if it is related but my host mentioned they tightened security.

First issue: [E_WARNING] proc_open() has been disabled for security reasons I notice new emails are not going out after someone registers.

Second issue: Your server has disabled a fundamental core PHP function ini_set via the disable_functions directive in php.ini.

I changed memory limit on PHP from 128 to 512 but not sure if this will fix the ini_set issue.
Your host has recently used php’s “Disable Functions”, this essentially prevents you from accessing certain functions, like proc_open and ini_set.

you’ll want to ask your host to make an exception for you, but if they’re tightening security, this might not be possible.

I would suggest looking for an alternative provider if it’s not possible for an exception.
 

vinnymickey

Active member
Would this error clear if I set up SMTP correct? Seems SMTP is working after I tested it via Xenforo test tool but error still won't clear.

error:Your server has disabled a fundamental core PHP function ini_set via the disable_functions directive in php.ini. This will cause unexpected problems in XenForo.
 
Last edited:
Top