proc_open() has been disabled... But the host fixed this

LenKaiser

Active member
I'm getting the following errors thrown anytime a email is sent out from the forum.

  • ErrorException: Email to xxxxxxx@gmail.com failed: [E_WARNING] proc_open() has been disabled for security reasons
  • src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php:299

Stack Trace:

#0 [internal function]: XF::handlePhpError(2, '[E_WARNING] pro...', '/home/xxx/...', 299, Array)
#1 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php(299): proc_open('/usr/sbin/sendm...', Array, Array)
#2 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php(54): Swift_Transport_StreamBuffer->establishProcessConnection()
#3 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/SendmailTransport.php(117): Swift_Transport_StreamBuffer->initialize(Array)
#4 src/XF/Mail/Mailer.php(304): Swift_Transport_SendmailTransport->send(Object(Swift_Message), Array)
#5 src/XF/Mail/Queue.php(138): XF\Mail\Mailer->send(Object(Swift_Message), Object(Swift_SendmailTransport), Array)
#6 src/XF/Job/MailQueue.php(12): XF\Mail\Queue->run(7.84451)
#7 src/XF/Job/Manager.php(258): XF\Job\MailQueue->run(7.84451)
#8 src/XF/Job/Manager.php(200): XF\Job\Manager->runJobInternal(Array, 7.84451)
#9 src/XF/Job/Manager.php(84): XF\Job\Manager->runJobEntry(Array, 7.84451)
#10 job.php(43): XF\Job\Manager->runQueue(false, 8)
#11 {main}

Request State:

array(4) {
["url"] => string(8) "/job.php"
["referrer"] => string(26) "https://mysite.com/"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}

I've seen numerous issues with this and read the threads but in the cases I read the host refused to fix it. In my instance my host says they have fixed it, but it is still an issue for my forum. Here is the screen of my php info. They say they fixed it by disabling the disable functions, which it has not fixed it.

screen1.png

Should this fix it or is my host playing with a setting that has no bearing on this problem?
 

LenKaiser

Active member
You might need to get a more competent host - or use SMTP.

The host can't change the local value of disable_functions to none as the change scope for this setting is PHP_INI_SYSTEM only.


So they either have to change the master value or they can't allow proc_open at all.
I have sent them that info we will see what happens. How to I engage the SMTP? I cannot find it anywhere in the ACP. Do you have a step by step how to on that? I cannot follow vague directions as I have a TBI and vague directions make no sense to me.
 

Kirby

Well-known member
You must fill in the data of your SMTP server, you will get this information from the provider or your SMTP server, nobody else would be able to tell you what you have to put there.
Either your host does offer SMTP services (in this case they should be able to provide you the necessary infirmation), or they dont (which is more likely).

In case they don't you might have to use a 3rd party SMTP service


Or just search for keywords like "SMTP Relay", "STMP Service", etc. on your favourite search engine - there are dozens of providers.
 

LenKaiser

Active member
SIGH.....I heard back from my host. Well this is a shared hosting account and apparently they cannot disable this globally. They suggested a VPS account, which I might do depending upon the price IDK.
 

LenKaiser

Active member
Yeah I'm sure that is the case as I've never had this issue before. I will hunt something better down next month when I have the money again :( For now I'm stuck with using the VPS from the same company.
 

Brogan

XenForo moderator
Staff member
How big is your site?

I personally use shared hosting from @MattW - very reasonable prices, comes with cPanel, and he even supports XFES (which is unusual for shared hosting).
 
Top