1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with xcache

Discussion in 'Server Configuration and Hosting' started by josemarialc, Nov 16, 2012.

  1. josemarialc

    josemarialc Member

    Again I have problems with xcache and the hosting. The did not want to set it as xcache xenforo says.

    The problem I have now is when you login to your account. When I returned to the forum not show logged. Disabling xcache the problem is resolved. I have also found that not all fluid is should the forum, when I have xcache enabled in the configuration.

    What I can do to fix this problem?
     
  2. josemarialc

    josemarialc Member

    My configuration of xcache.

    xcache.jpg
     
  3. MattW

    MattW Well-Known Member

    Have you set Xenforo to cache the settings in xcache as well? xcache is an opcode cacher, and should cache the php pages. Are you also setting xcache for the back end cache mechanism?

    On your server, how are you running php? DSO / FCGI / suPHP?
     
  4. josemarialc

    josemarialc Member

    My hosting said ITK. Xenforo as well configured. My hosting said ITK. XenForo settings right. I am attaching what I put in the config.

    Code:
    $config['cache'] = array(
        'enabled' => true,
        'frontend' => 'Core',
        'frontendOptions' => array(
                'caching' => true,
                'automatic_serialization' => false,
                'cache_id_prefix' => 'xf_aaa',
                'lifetime' => 18000
        ),
        'backend' => 'Xcache',
        'backendOptions' => array(),
        'cacheSessions' => true
    );
    I have sites with vbulletin and I have the same problem.
     
  5. josemarialc

    josemarialc Member

    Some parameters have changed to better match the xcache. But when in active XenForo xcache, the page takes longer than the active. The difference is about 200ms. How is it possible?
     
  6. josemarialc

    josemarialc Member

    Solved. The problem was xcache configuration. xcache_optimizer on / xcache_readonly_protection no value <--- solved the problem
     
  7. p4guru

    p4guru Well-Known Member

    You mean

    xcache_readonly_protection

    having no value was problem ?
     
  8. josemarialc

    josemarialc Member

    Yes. I do not understand why. But the problem is resolved.
     
  9. p4guru

    p4guru Well-Known Member

    i see, looks like default should be

    xcache.readonly_protection = Off
     

Share This Page