• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Problems with installation

#1
Hello,

I have just recently purchased a XenForo license, but once I click enter my mySQL details into the site I get this error, please help.
 

Jake Bunce

XenForo moderator
Staff member
#4
That simply means the MySQL info is wrong or the MySQL server is not properly configured. Confirm your MySQL connect info.

With some Windows servers I find that I need to use "127.0.0.1" for the host instead of "localhost". It's something to try...
 
#5
@Jake Bunce
It didn't work, thanks for your contribution though

@Lycaon
I don't know what config file your talking about

Extra Info
I tested my mySQL info on Sequel Pro (I'm on mac, I created the database with MAMP), and it connects just fine.
 

Jake Bunce

XenForo moderator
Staff member
#7
Also, thought I would add that I didn't get an internal_data folder, so I created the directory, but it has nothing in it.
The upgrade package excludes that directory. For a new install you should download the full package.

Extra Info
I tested my mySQL info on Sequel Pro (I'm on mac, I created the database with MAMP), and it connects just fine.
On what server are you installing XenForo? Your local machine? The db needs to be created on the same server as XenForo.
 
#8
eekelmo said:
Also, thought I would add that I didn't get an internal_data folder, so I created the directory, but it has nothing in it.​
The upgrade package excludes that directory. For a new install you should download the full package.

eekelmo said:
Extra Info
I tested my mySQL info on Sequel Pro (I'm on mac, I created the database with MAMP), and it connects just fine.​
On what server are you installing XenForo? Your local machine? The db needs to be created on the same server as XenForo.
I installed XenForo onto my web hosts FTP server.
 

14DH01

Active member
#12
like you said Jake,​
in the admin panel of your hosting provider you need to create a database(phpmyadmin).​
Once credentials are created, you must fill in the fields for your XenForo works like in your first picture:rolleyes:
This test lets you know if the server database is good​
XenForo System Requirements
  • PHP: 5.2.4+
  • MySQL: 5.0+
  • PHP extensions: MySQLi, GD (with JPEG support), PCRE, SPL, SimpleXML, DOM, JSON, iconv, ctype
  • PHP safe_mode off
 
#13
like you said Jake,
in the admin panel of your hosting provider you need to create a database.
Once credentials are created, you must fill in the fields for your XenForo works like in your first picture
This test lets you know if the server database is good
Thank you, I managed to do that, although when I enter the information for my hosts mySQL I get access denied for user "my username" (using password:YES)

I believe another error, is that I haven't set the permissions for data and internal_data, as I have no idea how. I apologize for my "noobiness".
 

14DH01

Active member
#15
The upgrade package excludes that directory. For a new install you should download the full package.
Thank you, I managed to do that, although when I enter the information for my hosts mySQL I get access denied for user "my username" (using password:YES)

I believe another error, is that I haven't set the permissions for data and internal_data, as I have no idea how. I apologize for my "noobiness".
for a new installation, you leave it blank
http://xenforo.com/customers/
 

14DH01

Active member
#19
completely empty FTP directory: www /*all files (ou public_html/*all files).​
:rolleyes: send from the zip "xenforo" install.​
Then in phpmyadmin also remove all tables "xf".​
Start a new install​