1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Problem with upgrade to 1.2.3

Discussion in 'Installation, Upgrade, and Import Support' started by a.tushkanov, Nov 9, 2013.

  1. a.tushkanov

    a.tushkanov Active Member

    I do everything according to the instructions as usual and after copying files got this:

    Server Error
    No entry is registered for key 'db'

    1. XenForo_Application::get() in XenForo/Application.php at line 1336
    2. XenForo_Application::getDb() in XenForo/Session.php at line 232
    3. XenForo_Session->__construct() in XenForo/Install/Controller/Upgrade.php at line 46
    4. XenForo_Install_Controller_Upgrade->_setupSession() in XenForo/Controller.php at line 304
    5. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 336
    6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    7. XenForo_FrontController->run() in /home/ldportal/data/www/xf.ldportal.ru/forum/install/index.php at line 18
    any ideas? ^(
    Last edited: Nov 10, 2013
  2. Mike

    Mike XenForo Developer Staff Member

  3. a.tushkanov

    a.tushkanov Active Member

    @Mike , already try to re-upload all files but no result. i noticed today, that during the first upload there was a internet connection lost. So maybe this is a result of what i have now.
    Going to link you gave - redirecting to install, but i dont need it. i need update.
    So this is 1 more example of what one should always:
    1. make a backup copy of the database
    2. use test address for rolling upgrades

    But I still do not understand why re-uploading files did not help :(
  4. Mike

    Mike XenForo Developer Staff Member

    That is the issue -- the upload may not have been "merged", so either library/config.php or internal_data/install-lock.php has been wiped out.

    If it's the first one, start the install process and have it generate that file for you but don't go any further. Then go to http://xf.ldportal.ru/forum/install/index.php?upgrade/ and it should work.
    If it's the second one, simply create the file - it can be empty, it just needs to exist. (If this file has been wiped out, it's possible that attachments and avatars have been removed.)
    a.tushkanov likes this.
  5. a.tushkanov

    a.tushkanov Active Member

    Omg, it works! There was no hope, Mike, but you did it! Thank you :)
    So the problem was that during the uploading upgrade files something happens with config.php, right?
    I guess maybe i was not checkboxed "merge" for library directory...
  6. Carlos

    Carlos Well-Known Member

    When upgrading, you're actually overwriting your files. So, whenever you update a software such as xenForo, think of it as overwrite.

Share This Page