• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Browser issue Post controls no longer pinned to bottom of post

Affected version
Version live here as at 12th September 2017, 17:20 BST

Chris D

XenForo developer
Staff member
#2
Weird.

Still like that here (Chrome Version 60.0.3112.113 macOS).

1505233330198.png

Chrome has just updated though so better restart the browser...

EDIT: All good in Chrome Version 61.0.3163.79
 

Chris D

XenForo developer
Staff member
#11
You know, we did make one change.

We removed min-height: 100px; from .message-content.

That will have most likely disguised that the original change never actually worked (because the 100px was about the same size as the roughly average height of the container anyway).
 

Chris D

XenForo developer
Staff member
#12
Ok, so we've confirmed that this is a bug in Safari and is fixed in Safari 11.

On the basis that it is a browser issue and that the adoption rate of macOS is ridiculously quick, we'll just tag this as such.

FWIW it's a manifestation of the bug that prevented height: 100% from working in flex containers which we also had reported on the demo in the context of sidebar blocks on wider displays:

Safari 10.x:

1505235229820.png

Safari 11.0:

1505235267598.png

If you're not planning to upgrade to High Sierra (it's going to be released today or within the next couple of weeks at most) then you can download Safari 11 beta here:

https://developer.apple.com/safari/download/
 

Liam W

Well-known member
#13
If you're not planning to upgrade to High Sierra (it's going to be released today or within the next couple of weeks at most) then you can download Safari 11 beta here:
I was on the beta, but I had to restore due to issues with sleep on my MacBook :( I'll be upgrading to the stable when it's released though.

Liam