• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Possible Permissions problem

Michael

Active member
#1
Okay so I have an announcements forum which I only want admins to be able to make new threads in. I change Registered Users for the forum to Never for creating a new thread and set the Admin group to Allow for the forum for all options.

I couldnt see the new thread button as an admin and the only way I could see it is when I make the registered users group have "revoke" rather than never.

Is this a bug or is this how it is meant to be.
 

Will

Active member
#2
Okay so I have an announcements forum which I only want admins to be able to make new threads in. I change Registered Users for the forum to Never for creating a new thread and set the Admin group to Allow for the forum for all options.

I couldnt see the new thread button as an admin and the only way I could see it is when I make the registered users group have "revoke" rather than never.

Is this a bug or is this how it is meant to be.
Are you also apart of the Registered Users usergroup?
 

Michael

Active member
#4
Are you also apart of the Registered Users usergroup?
Hang on no wonder I thought I wasnt part of registered, on my info page it says this at the top which mislead me:

Super Administrator Administrator Moderator

I thought they were the groups I belonged too.
 

Brogan

XenForo moderator
Staff member
#5
No, that is just the user administrator and moderator status.

By default, all members should have their primary group set as Registered, due to the way permissions are applied in a cumulative manner.

http://xenforo.com/help/user-groups/

You can check which groups any user is a member of (primary and secondary) by viewing the individual user page in the ACP.
 
F

Floris

Guest
#6
As you can see the primary group is set, no secondary groups are set,
but it says in the top super admin, admin and moderator.
Those are different than the usergroups.

Super-admin is set in the config.php file btw.
And mod/admin is set via the left menu as per screenshot (left side column)
Screen shot 2011-10-03 at 11.15.56 AM.png