1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Possible issues with older version of PHP?

Discussion in 'Installation, Upgrade, and Import Support' started by learningcurve, Jan 24, 2015.

  1. learningcurve

    learningcurve New Member

    I actually asked a rep on my hosting what version my server was running on, and he told me 5.4. I thought sweet, I'll buy this then, and I did. Turns out that he was wrong and I'm running a older version. Now, with the install I get this message:


    Now it says I can begin, but it also tells me I may have issues. What issues may I have? Is it worth giving it a shot? Or have I simply wasted my money?
  2. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    Just out of curiosity have you considered a new host one that keeps necessary things like PHP up to date? As far as issues I have no clue what might happen. As cheap as hosting is these days you'd be better off getting a new host.
  3. learningcurve

    learningcurve New Member

    Thanks for that enlightening reply.

    Never mind with the question anyway, they are updating it for me as we speak.
  4. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    Well good to know they are updating it for you.
    learningcurve likes this.
  5. learningcurve

    learningcurve New Member

    Thanks! It didn't seem like the option was available when I first spoke to the rep. All sorted now. I would still interested to know the issues that may have been created by it though, now that I think about it. :)
  6. rainmotorsports

    rainmotorsports Well-Known Member

    Its a real good thing they are upgrading as you might find issues with some plugins on less than 5.3 as well. I recommend 5.3 if you have some legacy software that's stuck on it otherwise very few reasons not to jump to 5.6. Next versions probably going to break a lot when it comes out though.
    Xon and learningcurve like this.
  7. learningcurve

    learningcurve New Member

    Cool, the rep suggested 5.4, so I went with that. I fully expect there to be issues with some of my sites, but I have stuffed them up so completely in the past, that I'm pretty sure I can reslove most of those issues now lol . :D

    Thanks for taking the time to reply. :)
  8. Mike

    Mike XenForo Developer Staff Member

    Just to answer this anyway, we currently support PHP 5.2 so you shouldn't have fundamental issues, but PHP 5.2 doesn't support the "good" password hashing system and it's slower when formatting dates.

    More fundamentally, PHP 5.2 (and now 5.3) have both reached their end of life and are not being supported by the PHP group. Unless your OS is backporting security fixes, there will be security issues in PHP 5.2 and 5.3 that will not be fixed (even if they are backporting, there is always talk of them missing fixes).
    Liam W and learningcurve like this.

Share This Page