XF 1.5 Latest version of PHP/SQL compatible with 1.5 and 2.1

Moddis

Active member
I'm currently running Xenforo 1.5 with PHP 5.4 and SQL 5.6. I am testing an upgrade to 2.1 on the same server which recommends PHP 7.2. I'm happy to upgrade but don't want to break the production site if it is not compatible with the latest PHP version.

What is the latest PHP version that is compatible with Xenforo 1.5 and 2.1? What about SQL version?

Also, if I change from using MySQL 5.6 to MariaDB 10.3, will it require any additional configuration/migration or will it work right away?
 

Solidus

Well-known member
MariaDB is a drop-in replacement for MySQL, there should be no issues and no configuration.
XF 2.1 works great on PHP 7.3.5.
 
Top