Please enter a message with no more than 420 characters

DarkVodka

Formerly Wuebit
library/XenForo/DataWriter/ProfilePostComment.php (at a guess)

PHP:
protected function _preSave()
    {
        if ($this->isChanged('message'))
        {
            $maxLength = 420;
            if (utf8_strlen($this->get('message')) > $maxLength)
            {
                $this->error(new XenForo_Phrase('please_enter_message_with_no_more_than_x_characters', array('count' => $maxLength)), 'message');
 

Brogan

XenForo moderator
Staff member
I think this may be hardcoded as I've never seen a setting for it in the ACP.

Edit: Confirmed by Vodkaholic above.
 

caoanh204

Active member
More... open library/XenForo/DataWriter/DiscussionMessage/ProfilePost.php

Find and fix: $maxLength = 140;
$options[self::OPTION_MAX_MESSAGE_LENGTH] = 420;
 

James

Well-known member
You might also have to edit the database field if it has a max value attached to it. Also in the getFields function.
 

SneakyDave

Well-known member
I'll see how easy this is to put into an addon. No promises though, lol.

I think I can easily make the 420 character limit an option.
 

SneakyDave

Well-known member
The page title is a different limit and beast, because it is set at VARCHAR(50) in the database schema, so in order to change that, the database structure would have to change, which may affect other nodes, such as forum and forum category name
 
Top